summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-demo/momiplay
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 11:33:17 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 15:43:04 +0200
commit13169c3265ba75d783eb3723504298a08e768110 (patch)
tree9f30b921d3491ad9bc8a55d58fd3bf6f3db8800e /meta-agl-ic-container/recipes-demo/momiplay
parentce87122d195d3a1fea454cfa4acd91e22ccea264 (diff)
Rename Instrument Cluster Container layer
meta-agl-lxc is no longer reflecting the actual content and use of the layer. Rename it to 'meta-agl-ic-container' and the feature to 'agl-ic-container'. Also rename the main image to 'agl-cluster-demo-lxc-host' to match the pattern used by all other images e.g. agl-<ivi,cluster,telematics>-demo-* . But keep the names of the underlying images as-is. Bug-AGL: SPEC-4464 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I898c786ca884331b302a3be8e150379fcf5bdc9b
Diffstat (limited to 'meta-agl-ic-container/recipes-demo/momiplay')
-rw-r--r--meta-agl-ic-container/recipes-demo/momiplay/momiplay/momiplay8
-rw-r--r--meta-agl-ic-container/recipes-demo/momiplay/momiplay/momiplay.service12
-rw-r--r--meta-agl-ic-container/recipes-demo/momiplay/momiplay_git.bb48
3 files changed, 68 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-demo/momiplay/momiplay/momiplay b/meta-agl-ic-container/recipes-demo/momiplay/momiplay/momiplay
new file mode 100644
index 00000000..be5a97a1
--- /dev/null
+++ b/meta-agl-ic-container/recipes-demo/momiplay/momiplay/momiplay
@@ -0,0 +1,8 @@
+XDG_RUNTIME_DIR=/run/user/0
+QT_QPA_PLATFORM=wayland-egl
+QT_WAYLAND_DISABLE_WINDOWDECORATION=1
+QT_QPA_FONTDIR=/usr/share/fonts/truetype
+QT_IVI_SURFACE_ID=2011
+QT_WAYLAND_SHELL_INTEGRATION=ivi-shell
+WAYLAND_DISPLAY=wayland-1
+HOME=/home/root
diff --git a/meta-agl-ic-container/recipes-demo/momiplay/momiplay/momiplay.service b/meta-agl-ic-container/recipes-demo/momiplay/momiplay/momiplay.service
new file mode 100644
index 00000000..ef974023
--- /dev/null
+++ b/meta-agl-ic-container/recipes-demo/momiplay/momiplay/momiplay.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=momiplayer
+After=multi-user.target weston.service
+Requires=multi-user.target weston.service
+
+[Service]
+Type=simple
+EnvironmentFile=/etc/default/momiplay
+ExecStart=/usr/bin/momiplay
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-agl-ic-container/recipes-demo/momiplay/momiplay_git.bb b/meta-agl-ic-container/recipes-demo/momiplay/momiplay_git.bb
new file mode 100644
index 00000000..02fc6f66
--- /dev/null
+++ b/meta-agl-ic-container/recipes-demo/momiplay/momiplay_git.bb
@@ -0,0 +1,48 @@
+SUMMARY = "Momiyama mediaplayer example based on AGL sample app. at CC"
+DESCRIPTION = "The momiplay is a mediaplayer example based on AGL sample app. \
+ The momiplay is not require agl-appfw."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=17;md5=f4ad6901289f57f62d15bfefb5cc3633"
+
+DEPENDS = " \
+ qtbase \
+ qtquickcontrols2 \
+ qtgraphicaleffects \
+ qtsvg \
+ qtmultimedia \
+ "
+
+PV = "0.2.0"
+
+SRC_URI = "git://github.com/AGLExport/momiplayer.git;protocol=https;branch=master \
+ file://momiplay.service \
+ file://momiplay \
+ "
+SRCREV = "b4715bf924ea295feaaf8fbdb4a9c3da75f57591"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 systemd
+
+QT_INSTALL_PREFIX = "/usr"
+
+do_install:append() {
+ install -d ${D}/${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/momiplay.service ${D}/${systemd_unitdir}/system
+
+ install -m 0755 -d ${D}${sysconfdir}/default/
+ install -m 0755 ${WORKDIR}/momiplay ${D}${sysconfdir}/default/
+}
+
+FILES:${PN} += " \
+ ${systemd_unitdir} \
+ ${sysconfdir}/*/* \
+ "
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "momiplay.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"
+
+RDEPENDS:${PN} = " \
+ qtsvg \
+ qtmultimedia \
+ "