summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-graphics
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-08 14:47:21 -0400
committerScott Murray <scott.murray@konsulko.com>2024-05-08 15:05:58 -0400
commit6d7244e5e0f5f3da430e4fb05e185e214bcc5a49 (patch)
tree33a78169bcb8ce905f393826aba23dbcb384a08d /meta-agl-ic-container/recipes-graphics
parent4e80a5b1cfb7b1e1e3bb65661fe1816e577b8503 (diff)
meta-agl-ic-container: update wayland-ivi-extension for Weston 13
Update the wayland-ivi-extension recipe to use latest upstream master branch commit to get Weston 12 support, and apply the pending Weston 13 support PR as a patch. All previous local patches have been dropped. Bug-AGL: SPEC-5123 Change-Id: I88a5ba0500cecc241c1abc6b6babb805ec20631d Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-ic-container/recipes-graphics')
-rw-r--r--meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch62
-rw-r--r--meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0001-ivi-input-controller-update-to-weston-7-header-files.patch31
-rw-r--r--meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-update-to-weston-7-header-files.patch33
-rw-r--r--meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0003-ivi-id-agent-update-dependencies-to-build-on-weston-.patch31
-rw-r--r--meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0004-ivi-id-agent-update-dependencies-to-build-on-weston-.patch28
-rw-r--r--meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0005-Fix-buld-error-in-krikston.patch68
-rw-r--r--meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0006-Drop-weston-6-support-and-adjust-weston-7-8-10.patch31
-rw-r--r--meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb13
8 files changed, 67 insertions, 230 deletions
diff --git a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch
new file mode 100644
index 00000000..008d0f4b
--- /dev/null
+++ b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0001-Update-libweston-to-version-13.patch
@@ -0,0 +1,62 @@
+From e7984b2a8a7508cdbc3f269f4e0789edcfe8b30a Mon Sep 17 00:00:00 2001
+From: James Thomas <james.thomas@codethink.co.uk>
+Date: Thu, 22 Feb 2024 12:26:58 +0000
+Subject: [PATCH] Update libweston to version 13
+
+Upstream-Status: Submitted [https://github.com/COVESA/wayland-ivi-extension/pull/185]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+---
+ CMakeLists.txt | 2 +-
+ weston-ivi-shell/src/ivi-controller.c | 10 +++++-----
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d6428c2..5917875 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,7 +28,7 @@ include(GNUInstallDirs)
+ SET(IVI_EXTENSION_VERSION 2.3.2)
+ SET(ILM_API_VERSION 2.3.2)
+
+-SET(LIBWESTON_VER 12)
++SET(LIBWESTON_VER 13)
+
+ SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wno-unused-parameter" )
+ SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wno-unused-parameter" )
+diff --git a/weston-ivi-shell/src/ivi-controller.c b/weston-ivi-shell/src/ivi-controller.c
+index 4701aec..94ca83e 100644
+--- a/weston-ivi-shell/src/ivi-controller.c
++++ b/weston-ivi-shell/src/ivi-controller.c
+@@ -881,15 +881,15 @@ set_bkgnd_surface_prop(struct ivishell *shell)
+ wl_list_for_each(output, &compositor->output_list, link) {
+ if (!count)
+ {
+- x = output->x;
+- y = output->y;
++ x = output->pos.c.x;
++ y = output->pos.c.y;
+ count++;
+ }
+- dest_width = output->x + output->width;
++ dest_width = output->pos.c.x + output->width;
+ if (output->height > dest_height)
+ dest_height = output->height;
+ weston_log("set_bkgnd_surface_prop: o_name:%s x:%d y:%d o_width:%d o_height:%d\n",
+- output->name, output->x, output->y, output->width, output->height);
++ output->name, output->pos.c.x, output->pos.c.y, output->width, output->height);
+ }
+
+ w_surface = view->surface;
+@@ -2197,7 +2197,7 @@ launch_client_process(void *data)
+ setenv(IVI_CLIENT_ENABLE_CURSOR_ENV_NAME, option, 0x1);
+ }
+
+- shell->client = weston_client_start(shell->compositor,
++ shell->client = wet_client_start(shell->compositor,
+ shell->ivi_client_name);
+
+ shell->client_destroy_listener.notify = ivi_shell_client_destroy;
+--
+2.44.0
+
diff --git a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0001-ivi-input-controller-update-to-weston-7-header-files.patch b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0001-ivi-input-controller-update-to-weston-7-header-files.patch
deleted file mode 100644
index b19243e0..00000000
--- a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0001-ivi-input-controller-update-to-weston-7-header-files.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 6432f46f500321518e9a588215d4635ef7466692 Mon Sep 17 00:00:00 2001
-From: Rajendraprasad K J <KarammelJayakumar.Rajendraprasad@in.bosch.com>
-Date: Mon, 6 Jan 2020 06:41:57 -0500
-Subject: [PATCH 1/6] ivi-input-controller: update to weston 7 header files
-
-update the header file path.
-
-Upstream-Status: Submitted [https://github.com/GENIVI/wayland-ivi-extension/pull/110]
-
-Signed-off-by: Rajendraprasad K J <KarammelJayakumar.Rajendraprasad@in.bosch.com>
-Signed-off-by: Gowtham Tammana <g-tammana@ti.com>
----
- .../ivi-input-controller/src/ivi-input-controller.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c b/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
-index b4d54d1..8974115 100644
---- a/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
-+++ b/ivi-input-modules/ivi-input-controller/src/ivi-input-controller.c
-@@ -31,7 +31,7 @@
- #include <fcntl.h>
- #include <unistd.h>
-
--#include "plugin-registry.h"
-+#include <libweston/plugin-registry.h>
- #include "ilm_types.h"
-
- #include "ivi-input-server-protocol.h"
---
-2.17.1
-
diff --git a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-update-to-weston-7-header-files.patch b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-update-to-weston-7-header-files.patch
deleted file mode 100644
index 87e286ab..00000000
--- a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0002-ivi-id-agent-update-to-weston-7-header-files.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 7b7a5e96388f2431e750583a035962d261292b43 Mon Sep 17 00:00:00 2001
-From: Rajendraprasad K J <KarammelJayakumar.Rajendraprasad@in.bosch.com>
-Date: Mon, 6 Jan 2020 06:45:11 -0500
-Subject: [PATCH 2/6] ivi-id-agent: update to weston 7 header files
-
-update the header file path.
-
-Upstream-Status: Submitted [https://github.com/GENIVI/wayland-ivi-extension/pull/110]
-
-Signed-off-by: Rajendraprasad K J <KarammelJayakumar.Rajendraprasad@in.bosch.com>
-Signed-off-by: Gowtham Tammana <g-tammana@ti.com>
----
- ivi-id-agent-modules/ivi-id-agent/src/ivi-id-agent.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/ivi-id-agent-modules/ivi-id-agent/src/ivi-id-agent.c b/ivi-id-agent-modules/ivi-id-agent/src/ivi-id-agent.c
-index 8f0c199..b80e2a4 100644
---- a/ivi-id-agent-modules/ivi-id-agent/src/ivi-id-agent.c
-+++ b/ivi-id-agent-modules/ivi-id-agent/src/ivi-id-agent.c
-@@ -26,8 +26,8 @@
- #include <limits.h>
-
- #include <weston.h>
--#include <libweston-6/libweston-desktop.h>
--#include "config-parser.h"
-+#include <libweston-desktop/libweston-desktop.h>
-+#include <libweston/config-parser.h>
- #include <weston/ivi-layout-export.h>
-
- #ifndef INVALID_ID
---
-2.17.1
-
diff --git a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0003-ivi-id-agent-update-dependencies-to-build-on-weston-.patch b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0003-ivi-id-agent-update-dependencies-to-build-on-weston-.patch
deleted file mode 100644
index dcb21a1a..00000000
--- a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0003-ivi-id-agent-update-dependencies-to-build-on-weston-.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 46ef7140611d684d1dbecd866608333e67a1985e Mon Sep 17 00:00:00 2001
-From: Rajendraprasad K J <KarammelJayakumar.Rajendraprasad@in.bosch.com>
-Date: Mon, 6 Jan 2020 06:45:54 -0500
-Subject: [PATCH 3/6] ivi-id-agent: update dependencies to build on weston 8
-
-upgrade libweston-desktop version.
-
-Upstream-Status: Submitted [https://github.com/GENIVI/wayland-ivi-extension/pull/110]
-
-Signed-off-by: Rajendraprasad K J <KarammelJayakumar.Rajendraprasad@in.bosch.com>
-Signed-off-by: Gowtham Tammana <g-tammana@ti.com>
----
- ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt b/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
-index 3e604a5..4f285c2 100644
---- a/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
-+++ b/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
-@@ -25,7 +25,7 @@ find_package(PkgConfig REQUIRED)
- pkg_check_modules(WAYLAND_SERVER wayland-server REQUIRED)
- pkg_check_modules(WESTON weston>=6.0.0 REQUIRED)
- pkg_check_modules(PIXMAN pixman-1 REQUIRED)
--pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-6 REQUIRED)
-+pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-8 REQUIRED)
-
- find_package(Threads REQUIRED)
-
---
-2.17.1
-
diff --git a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0004-ivi-id-agent-update-dependencies-to-build-on-weston-.patch b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0004-ivi-id-agent-update-dependencies-to-build-on-weston-.patch
deleted file mode 100644
index 509becb6..00000000
--- a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0004-ivi-id-agent-update-dependencies-to-build-on-weston-.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 7b301a1832c81d814a8475c8679eddd3d43f3487 Mon Sep 17 00:00:00 2001
-From: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
-Date: Thu, 28 Apr 2022 07:18:50 +0900
-Subject: [PATCH 4/6] ivi-id-agent: update dependencies to build on weston 10
-
-upgrade libweston-desktop version.
-
-Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
----
- ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt b/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
-index 4f285c2..a67ac5a 100644
---- a/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
-+++ b/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
-@@ -25,7 +25,7 @@ find_package(PkgConfig REQUIRED)
- pkg_check_modules(WAYLAND_SERVER wayland-server REQUIRED)
- pkg_check_modules(WESTON weston>=6.0.0 REQUIRED)
- pkg_check_modules(PIXMAN pixman-1 REQUIRED)
--pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-8 REQUIRED)
-+pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-10 REQUIRED)
-
- find_package(Threads REQUIRED)
-
---
-2.17.1
-
diff --git a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0005-Fix-buld-error-in-krikston.patch b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0005-Fix-buld-error-in-krikston.patch
deleted file mode 100644
index ab9c13f2..00000000
--- a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0005-Fix-buld-error-in-krikston.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From c54194acfc807fa3e1f5ce14e83826ebc6966ca7 Mon Sep 17 00:00:00 2001
-From: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
-Date: Thu, 28 Apr 2022 07:26:09 +0900
-Subject: [PATCH 5/6] Fix buld error in krikston
-
-Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
----
- ivi-layermanagement-api/ilmClient/include/ilm_client_platform.h | 2 +-
- .../ilmClient/src/ilm_client_wayland_platform.c | 2 ++
- ivi-layermanagement-api/ilmCommon/include/ilm_common_platform.h | 2 +-
- .../ilmCommon/src/ilm_common_wayland_platform.c | 2 ++
- 4 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/ivi-layermanagement-api/ilmClient/include/ilm_client_platform.h b/ivi-layermanagement-api/ilmClient/include/ilm_client_platform.h
-index 1fb10af..56368dc 100644
---- a/ivi-layermanagement-api/ilmClient/include/ilm_client_platform.h
-+++ b/ivi-layermanagement-api/ilmClient/include/ilm_client_platform.h
-@@ -35,7 +35,7 @@ typedef struct _ILM_CLIENT_PLATFORM_FUNC
- ilmErrorTypes (*destroy)();
- } ILM_CLIENT_PLATFORM_FUNC;
-
--ILM_CLIENT_PLATFORM_FUNC gIlmClientPlatformFunc;
-+extern ILM_CLIENT_PLATFORM_FUNC gIlmClientPlatformFunc;
-
- void init_ilmClientPlatformTable();
-
-diff --git a/ivi-layermanagement-api/ilmClient/src/ilm_client_wayland_platform.c b/ivi-layermanagement-api/ilmClient/src/ilm_client_wayland_platform.c
-index 55b1621..8786251 100644
---- a/ivi-layermanagement-api/ilmClient/src/ilm_client_wayland_platform.c
-+++ b/ivi-layermanagement-api/ilmClient/src/ilm_client_wayland_platform.c
-@@ -35,6 +35,8 @@ static ilmErrorTypes wayland_surfaceRemove(const t_ilm_surface surfaceId);
- static ilmErrorTypes wayland_init(t_ilm_nativedisplay nativedisplay);
- static ilmErrorTypes wayland_destroy(void);
-
-+ILM_CLIENT_PLATFORM_FUNC gIlmClientPlatformFunc;
-+
- void init_ilmClientPlatformTable(void)
- {
- gIlmClientPlatformFunc.surfaceCreate =
-diff --git a/ivi-layermanagement-api/ilmCommon/include/ilm_common_platform.h b/ivi-layermanagement-api/ilmCommon/include/ilm_common_platform.h
-index 4e7b55e..ec49467 100644
---- a/ivi-layermanagement-api/ilmCommon/include/ilm_common_platform.h
-+++ b/ivi-layermanagement-api/ilmCommon/include/ilm_common_platform.h
-@@ -32,7 +32,7 @@ typedef struct _ILM_COMMON_PLATFORM_FUNC
- ilmErrorTypes (*destroy)();
- } ILM_COMMON_PLATFORM_FUNC;
-
--ILM_COMMON_PLATFORM_FUNC gIlmCommonPlatformFunc;
-+extern ILM_COMMON_PLATFORM_FUNC gIlmCommonPlatformFunc;
-
- void init_ilmCommonPlatformTable();
-
-diff --git a/ivi-layermanagement-api/ilmCommon/src/ilm_common_wayland_platform.c b/ivi-layermanagement-api/ilmCommon/src/ilm_common_wayland_platform.c
-index 7470d0d..eef842d 100644
---- a/ivi-layermanagement-api/ilmCommon/src/ilm_common_wayland_platform.c
-+++ b/ivi-layermanagement-api/ilmCommon/src/ilm_common_wayland_platform.c
-@@ -32,6 +32,8 @@ static t_ilm_nativedisplay wayland_getNativedisplay(void);
- static t_ilm_bool wayland_isInitialized(void);
- static ilmErrorTypes wayland_destroy(void);
-
-+ILM_COMMON_PLATFORM_FUNC gIlmCommonPlatformFunc;
-+
- void init_ilmCommonPlatformTable(void)
- {
- gIlmCommonPlatformFunc.init = wayland_init;
---
-2.17.1
-
diff --git a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0006-Drop-weston-6-support-and-adjust-weston-7-8-10.patch b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0006-Drop-weston-6-support-and-adjust-weston-7-8-10.patch
deleted file mode 100644
index 035e597b..00000000
--- a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension/0006-Drop-weston-6-support-and-adjust-weston-7-8-10.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From d25c266858ffbea51b435190ea8697d4a4511355 Mon Sep 17 00:00:00 2001
-From: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
-Date: Thu, 28 Apr 2022 08:00:07 +0900
-Subject: [PATCH 6/6] Drop weston 6 support and adjust weston 7,8,10
-
-Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
----
- ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt b/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
-index a67ac5a..a4b4e1a 100644
---- a/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
-+++ b/ivi-id-agent-modules/ivi-id-agent/CMakeLists.txt
-@@ -23,9 +23,11 @@ project(ivi-id-agent)
-
- find_package(PkgConfig REQUIRED)
- pkg_check_modules(WAYLAND_SERVER wayland-server REQUIRED)
--pkg_check_modules(WESTON weston>=6.0.0 REQUIRED)
-+pkg_check_modules(WESTON weston>=7.0.0 REQUIRED)
- pkg_check_modules(PIXMAN pixman-1 REQUIRED)
--pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-10 REQUIRED)
-+pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-10)
-+pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-8)
-+pkg_check_modules(LIBWESTON_DESKTOP libweston-desktop-7)
-
- find_package(Threads REQUIRED)
-
---
-2.17.1
-
diff --git a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb
index b99331aa..56090f5d 100644
--- a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb
+++ b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb
@@ -6,16 +6,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
DEPENDS = "weston virtual/libgles2 pixman wayland-native"
+PV = "2.3.2+git${SRCPV}"
+
SRC_URI = " \
git://github.com/COVESA/${BPN}.git;protocol=https;branch=master \
- file://0001-ivi-input-controller-update-to-weston-7-header-files.patch \
- file://0002-ivi-id-agent-update-to-weston-7-header-files.patch \
- file://0003-ivi-id-agent-update-dependencies-to-build-on-weston-.patch \
- file://0004-ivi-id-agent-update-dependencies-to-build-on-weston-.patch \
- file://0005-Fix-buld-error-in-krikston.patch \
- file://0006-Drop-weston-6-support-and-adjust-weston-7-8-10.patch \
- "
-SRCREV = "f6911a11dc911a5bcb380d0895db6cfd533a3569"
+ file://0001-Update-libweston-to-version-13.patch \
+"
+SRCREV = "60d616ad3abd925956207b9b6ff981afa004e792"
S = "${WORKDIR}/git"