summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-11-02 16:13:39 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-05 17:37:35 +0000
commit43c2dac50d6c8a38b1d8a89a86d146ea9539140d (patch)
treefa56f76d185bc22128a4c5be02ccc1b7d3d8ca8d /meta-agl-ic-container/recipes-platform
parent64889c4c525c4c66fb74dd703a1cbc0375bc405d (diff)
Add initial DRM lease test images
Add guest and host image as well as associated configuration recipes for simple DRM lease testing. The agl-host-image-drm-least-test image has two guests that each run Weston + desktop-shell with a different background color. A known issue at the moment is that networking is not functional in the guests, this will be investigated further. Bug-AGL: SPEC-4955 Change-Id: Ib69e627bb251180c2d7a1175de53d2fb1561aa61 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-ic-container/recipes-platform')
-rw-r--r--meta-agl-ic-container/recipes-platform/images/agl-host-image-drm-lease-test.bb27
-rw-r--r--meta-agl-ic-container/recipes-platform/images/guest-image-drm-lease-test-cluster.bb13
-rw-r--r--meta-agl-ic-container/recipes-platform/images/guest-image-drm-lease-test-ivi.bb13
3 files changed, 53 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-platform/images/agl-host-image-drm-lease-test.bb b/meta-agl-ic-container/recipes-platform/images/agl-host-image-drm-lease-test.bb
new file mode 100644
index 00000000..09b6ddac
--- /dev/null
+++ b/meta-agl-ic-container/recipes-platform/images/agl-host-image-drm-lease-test.bb
@@ -0,0 +1,27 @@
+SUMMARY = "DRM Lease LXC test host image"
+LICENSE = "MIT"
+
+require lxc-host-image-minimal.bb
+require recipes-platform/images/agl-lxc-install-single-image.inc
+require recipes-platform/images/agl-lxc-autostart.inc
+
+CONTAINER_IMAGES ?= "agl-container-ivi:guest-image-drm-lease-test-ivi \
+ agl-container-cluster:guest-image-drm-lease-test-cluster \
+ "
+
+IMAGE_INSTALL += " \
+ kernel-modules \
+"
+
+# packages required for network bridge settings via lxc-net
+IMAGE_INSTALL += " \
+ lxc-networking \
+ iptables-modules \
+ dnsmasq \
+ systemd-netif-config \
+ kernel-module-xt-addrtype \
+ kernel-module-xt-multiport \
+"
+
+# Under the this line, shall describe machine specific package.
+IMAGE_INSTALL:append:rcar-gen3 = " kernel-module-gles gles-user-module-firmware"
diff --git a/meta-agl-ic-container/recipes-platform/images/guest-image-drm-lease-test-cluster.bb b/meta-agl-ic-container/recipes-platform/images/guest-image-drm-lease-test-cluster.bb
new file mode 100644
index 00000000..13563da8
--- /dev/null
+++ b/meta-agl-ic-container/recipes-platform/images/guest-image-drm-lease-test-cluster.bb
@@ -0,0 +1,13 @@
+SUMMARY = "DRM Lease LXC test guest image"
+LICENSE = "MIT"
+
+require guest-image-minimal.bb
+
+IMAGE_INSTALL += " \
+ systemd-netif-config \
+ weston \
+ weston-init-guest \
+ weston-ini-conf-drm-lease-test-cluster \
+"
+
+IMAGE_INSTALL:append:raspberrypi4 = " mesa-megadriver"
diff --git a/meta-agl-ic-container/recipes-platform/images/guest-image-drm-lease-test-ivi.bb b/meta-agl-ic-container/recipes-platform/images/guest-image-drm-lease-test-ivi.bb
new file mode 100644
index 00000000..be8fcbff
--- /dev/null
+++ b/meta-agl-ic-container/recipes-platform/images/guest-image-drm-lease-test-ivi.bb
@@ -0,0 +1,13 @@
+SUMMARY = "DRM Lease LXC test guest image"
+LICENSE = "MIT"
+
+require guest-image-minimal.bb
+
+IMAGE_INSTALL += " \
+ systemd-netif-config \
+ weston \
+ weston-init-guest \
+ weston-ini-conf-drm-lease-test-ivi \
+"
+
+IMAGE_INSTALL:append:raspberrypi4 = " mesa-megadriver"