summaryrefslogtreecommitdiffstats
path: root/meta-agl-jailhouse/conf
diff options
context:
space:
mode:
authorJakub Luzny <jakub@luzny.cz>2020-07-19 17:00:08 +0200
committerJakub Luzny <jakub@luzny.cz>2020-07-24 12:46:57 +0200
commit3f6d193683449a323a3f1d689540ab697d3d7980 (patch)
tree093ad36c5bf3f031d469a635d0f2190a57c176e0 /meta-agl-jailhouse/conf
parentc6889de97c1af6baa7ee8006aa75da170c9bd407 (diff)
Add layer to support Jailhouse hypervisorjellyfish_9.99.2jellyfish/9.99.29.99.2
Jailhouse is a partitioning hypervisor based on Linux. It is able to run bare-metal applications or (adapted) operating systems besides Linux. For this purpose, it configures CPU and device virtualization features of the hardware platform in a way that none of these domains, called "cells" here, can interfere with each other in an unacceptable way. This layer adds the Jailhouse package into AGL and also appends the BSPs to allow it to run. Currently, Raspberry Pi 4 and QEMU x86-64 targets are supported. To enable Jailhouse and include it in the image, the AGL feature agl-jailhouse must be enabled. Bug-AGL: SPEC-3507 Signed-off-by: Jakub Luzny <jakub@luzny.cz> Change-Id: I0fbc0b5d931c85d6f22b0222da8c2b106c4115e1
Diffstat (limited to 'meta-agl-jailhouse/conf')
-rw-r--r--meta-agl-jailhouse/conf/layer.conf23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-agl-jailhouse/conf/layer.conf b/meta-agl-jailhouse/conf/layer.conf
new file mode 100644
index 00000000..2031e788
--- /dev/null
+++ b/meta-agl-jailhouse/conf/layer.conf
@@ -0,0 +1,23 @@
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "agl-jailhouse"
+BBFILE_PATTERN_agl-jailhouse := "^${LAYERDIR}/"
+BBFILE_PRIORITY_agl-jailhouse = "61"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_agl-jailhouse = "1"
+LAYERSERIES_COMPAT_agl-jailhouse = "dunfell"
+
+# This is only needed for Raspberry Pi
+# TODO: can this be expressed dynamically?
+LAYERDEPENDS_agl-jailhouse = "meta-arm"
+
+BBFILES_DYNAMIC += " \
+ raspberrypi:${LAYERDIR}/dynamic-layers/raspberrypi/*/*/*.bbappend \
+"
+