summaryrefslogtreecommitdiffstats
path: root/meta-agl-jailhouse
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
commit37d3b1b316470fdcfebc59d5522bfbfefc025ff6 (patch)
treecf70d6c9e3832d8734de4f66f2d0fe52b104c9fd /meta-agl-jailhouse
parentab5f7f52dbdbea04d1f79310cbf08922a5371345 (diff)
Convert to new override syntax
This is mostly the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. A few minor fixups were done by hand afterwards during a review of the changes. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I0bbae97331abee1367b368ce54ab39e3162a12ec
Diffstat (limited to 'meta-agl-jailhouse')
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend2
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend2
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-extended/jailhouse/jailhouse_%.bbappend2
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4%.bbappend2
-rw-r--r--meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb18
-rw-r--r--meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/kernel-devsrc.bb10
-rw-r--r--meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-5.14.inc4
-rw-r--r--meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-custom_git.bb2
8 files changed, 21 insertions, 21 deletions
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 687980cf..ce7b0227 100644
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -1,5 +1,5 @@
-do_deploy_append_raspberrypi4() {
+do_deploy:append:raspberrypi4() {
# if ARMSTUB is set, it should be set in config.txt by earlier recipes, so replace it
if [ -n "${ARMSTUB}" ]; then
sed -i 's/^armstub=.*/armstub=bl31.bin/' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 158eb6e8..e84d2409 100644
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -6,7 +6,7 @@ TFA_PLATFORM = "rpi4"
# partition that is generated from the files in DEPLOYDIR
do_install[noexec] = "1"
-FILES_${PN} = ""
+FILES:${PN} = ""
do_deploy() {
if ${@"true" if d.getVar('TFA_DEBUG') == '1' else "false"}; then
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-extended/jailhouse/jailhouse_%.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-extended/jailhouse/jailhouse_%.bbappend
index 1d8ea6b7..b1f29275 100644
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-extended/jailhouse/jailhouse_%.bbappend
+++ b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-extended/jailhouse/jailhouse_%.bbappend
@@ -1,2 +1,2 @@
-DEPENDS_append_raspberrypi4 = " trusted-firmware-a"
+DEPENDS:append:raspberrypi4 = " trusted-firmware-a"
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4%.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4%.bbappend
index 1456fdc8..ba3505fe 100644
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4%.bbappend
+++ b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://0001-dt-dtoverlays-Add-jailhouse-memory-DT-overlay.patch"
diff --git a/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb b/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
index cc75d684..87519e19 100644
--- a/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
+++ b/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
@@ -13,7 +13,7 @@ LIC_FILES_CHKSUM = " \
SRCREV = "630001202caec85370fb4f956e581f51109e490c"
PV = "0.12+git${SRCPV}"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI = "git://github.com/siemens/jailhouse \
file://qemu-agl.c \
@@ -81,18 +81,18 @@ do_install() {
}
PACKAGE_BEFORE_PN = "kernel-module-jailhouse pyjailhouse ${PN}-tools ${PN}-demos"
-FILES_${PN} = "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}"
-FILES_pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}"
-FILES_${PN}-tools = "${libexecdir}/${BPN}/${BPN}-* ${JH_DATADIR}/*.tmpl"
-FILES_${PN}-demos = "${JH_DATADIR}/ ${sbindir}/ivshmem-demo"
+FILES:${PN} = "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}"
+FILES:pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}"
+FILES:${PN}-tools = "${libexecdir}/${BPN}/${BPN}-* ${JH_DATADIR}/*.tmpl"
+FILES:${PN}-demos = "${JH_DATADIR}/ ${sbindir}/ivshmem-demo"
# Default Linker Hash Style Changed to "sysv"
TARGET_CC_ARCH += "${LDFLAGS}"
-RDEPENDS_${PN}-tools = "pyjailhouse python3-mmap python3-math python3-datetime python3-curses python3-compression python3-mako"
-RDEPENDS_pyjailhouse = "python3-core python3-ctypes python3-fcntl"
-RDEPENDS_${PN}-demos = "jailhouse"
+RDEPENDS:${PN}-tools = "pyjailhouse python3-mmap python3-math python3-datetime python3-curses python3-compression python3-mako"
+RDEPENDS:pyjailhouse = "python3-core python3-ctypes python3-fcntl"
+RDEPENDS:${PN}-demos = "jailhouse"
-RRECOMMENDS_${PN} = "${PN}-tools"
+RRECOMMENDS:${PN} = "${PN}-tools"
KERNEL_MODULE_AUTOLOAD += "jailhouse"
diff --git a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/kernel-devsrc.bb b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/kernel-devsrc.bb
index f207a43c..8a6e4903 100644
--- a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/kernel-devsrc.bb
+++ b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/kernel-devsrc.bb
@@ -270,11 +270,11 @@ do_install() {
# Ensure we don't race against "make scripts" during cpio
do_install[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
-FILES_${PN} = "${KERNEL_BUILD_ROOT} ${KERNEL_SRC_PATH}"
-FILES_${PN}-dbg += "${KERNEL_BUILD_ROOT}*/build/scripts/*/.debug/*"
+FILES:${PN} = "${KERNEL_BUILD_ROOT} ${KERNEL_SRC_PATH}"
+FILES:${PN}-dbg += "${KERNEL_BUILD_ROOT}*/build/scripts/*/.debug/*"
-RDEPENDS_${PN} = "bc python3 flex bison ${TCLIBC}-utils"
+RDEPENDS:${PN} = "bc python3 flex bison ${TCLIBC}-utils"
# 4.15+ needs these next two RDEPENDS
-RDEPENDS_${PN} += "openssl-dev util-linux"
+RDEPENDS:${PN} += "openssl-dev util-linux"
# and x86 needs a bit more for 4.15+
-RDEPENDS_${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils', '', d)}"
+RDEPENDS:${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils', '', d)}"
diff --git a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-5.14.inc b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-5.14.inc
index 2807563d..7cc70c07 100644
--- a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-5.14.inc
+++ b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-5.14.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux:"
-SRC_URI_append = " file://jailhouse.cfg"
+SRC_URI:append = " file://jailhouse.cfg"
diff --git a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-custom_git.bb b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-custom_git.bb
index 6eb55e46..0e5818a2 100644
--- a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-custom_git.bb
+++ b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-custom_git.bb
@@ -20,4 +20,4 @@ PV = "5.14-rc2+git${SRCPV}"
KVER = "5.14"
DEPENDS += "ncurses-native bc-native pkgconfig-native"
-DEPENDS_append_x86-64 = " elfutils-native"
+DEPENDS:append:x86-64 = " elfutils-native"