summaryrefslogtreecommitdiffstats
path: root/meta-agl-test/recipes-tests
diff options
context:
space:
mode:
authoryanxk <yanxk.fnst@fujitsu.com>2023-07-24 03:06:57 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-03-22 13:34:28 +0000
commit9a991da4d017ff05f291316b6ead7be6bd5ded14 (patch)
treefaff34fa088063b8b0994b452dac7e23a0a2281e /meta-agl-test/recipes-tests
parentcf7a8c9527d04df829ed7bea3414bc9baeb04498 (diff)
meta-agl-test: add "linus_stress"
get this old core test into current agl-test-framework. re-write old bb file, make it working for agl-test-framework. Bug-AGL: SPEC-4345 Signed-off-by: yanxk <yanxk.fnst@fujitsu.com> Change-Id: I341b18516e2b3b57622239f47b4b40d2d4d4a160
Diffstat (limited to 'meta-agl-test/recipes-tests')
-rw-r--r--meta-agl-test/recipes-tests/linus-stress/linus-stress.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-agl-test/recipes-tests/linus-stress/linus-stress.bb b/meta-agl-test/recipes-tests/linus-stress/linus-stress.bb
new file mode 100644
index 00000000..4a190245
--- /dev/null
+++ b/meta-agl-test/recipes-tests/linus-stress/linus-stress.bb
@@ -0,0 +1,20 @@
+SUMMARY = "linus_stress test"
+HOMEPAGE = "https://chromium.googlesource.com/chromiumos/third_party/autotest/+/master/client/tests/linus_stress"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/linus_stress/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "87cdfd4626c0cb47fc22f328867e49d6268df85c"
+
+S = "${WORKDIR}/git/linus_stress"
+
+do_install() {
+ install -d ${D}/usr/AGL/agl-test/tests/linus_stress/resource/
+ install -m 0755 ${S}/linus_stress ${D}/usr/AGL/agl-test/tests/linus_stress/resource/
+}
+
+INSANE_SKIP:${PN} = "ldflags"
+
+FILES:${PN} += " \
+ /usr/AGL/agl-test/tests/linus_stress/resource \
+"