summaryrefslogtreecommitdiffstats
path: root/meta-audio-4a-framework/meta-agl-demo
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-07-13 11:46:51 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-07-13 11:46:51 +0200
commit63c6b83bc69eb8658aea8a200510ef8aadae1847 (patch)
tree0043ae6b7ed9b32dcab84648ab43d30194a78827 /meta-audio-4a-framework/meta-agl-demo
parentce8323a75aec9a3601284b83996895a4610344fa (diff)
Fix 4a-mixer parsing error on nogfx build variant
The nogfx build variant fails with 4a enabled ( https://gerrit.automotivelinux.org/gerrit/#/c/15051/ ) This is documented in SPEC-1588. To fix this we apply a conditional inclusion in meta-audio-4a-framework to only pull-in the mixer if we are including meta-agl-demo. Can be more fine-grained (profile-graphical-qt5 maybe) later. Bug-AGL: SPEC-1588 Fast inclusion requested as it is a blocker for RC2 due to enabling 4a in CI. Change-Id: I59b82748ba8e1736358318373d29f8f9fed2a5c5 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-audio-4a-framework/meta-agl-demo')
-rw-r--r--meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb b/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
new file mode 100644
index 00000000..c784ea6e
--- /dev/null
+++ b/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Mixer for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 \
+ qtwebsockets \
+ pulseaudio \
+ virtual/libhomescreen \
+ qlibwindowmanager \
+"
+
+RPROVIDES_${PN} += "virtual/mixer"
+
+inherit cmake_qt5 aglwgt \ No newline at end of file