summaryrefslogtreecommitdiffstats
path: root/meta-egvirt/recipes-kernel
diff options
context:
space:
mode:
authorAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2022-12-12 12:41:38 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-05-05 11:06:57 +0000
commit26cdf42b8a4d8f15768f93cf0895a359a3412638 (patch)
tree558b94b249cb5a1d243930e271185a232166767e /meta-egvirt/recipes-kernel
parented880f1f9df5ac8b4e335862d5bdfcf6cc3cc584 (diff)
virtio-loopback: v5: Add recipes for virtio-loopback support
Includes the virtio-loopback kernel module, the adapter application, the vhost-user devices from QEMU and a Rust vhost-user-rng device implementation. v2: Update recipes to conform with the OE-Styleguide v3: Recipes fixes for generic builds v4: Generalize the recipes to build for different architectures v5: Update recipes to comply with the OE-Styleguide Change-Id: I67c14fd77e564c0aecdde40dc1cf7e893dae6de1 Signed-off-by: Angelos Mouzakitis <a.mouzakitis@virtualopensystems.com>
Diffstat (limited to 'meta-egvirt/recipes-kernel')
-rw-r--r--meta-egvirt/recipes-kernel/kernel-module-virtio-loopback/loopbackdriver.bb14
-rw-r--r--meta-egvirt/recipes-kernel/linux/linux-yocto-dev.bbappend5
-rw-r--r--meta-egvirt/recipes-kernel/linux/linux-yocto/virtio_loopback.cfg2
-rw-r--r--meta-egvirt/recipes-kernel/linux/linux-yocto_%.bbappend5
4 files changed, 26 insertions, 0 deletions
diff --git a/meta-egvirt/recipes-kernel/kernel-module-virtio-loopback/loopbackdriver.bb b/meta-egvirt/recipes-kernel/kernel-module-virtio-loopback/loopbackdriver.bb
new file mode 100644
index 00000000..d5c13a21
--- /dev/null
+++ b/meta-egvirt/recipes-kernel/kernel-module-virtio-loopback/loopbackdriver.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Virtio-loopback driver"
+DESCRIPTION = "Virtio-Loopback kernel driver"
+LICENSE = "GPL"
+LIC_FILES_CHKSUM = "file://README.md;md5=c912e5645ed908bc9570ba05c92b3723"
+
+inherit module
+
+SRC_URI = "git://git.virtualopensystems.com/virtio-loopback/loopback_driver.git;protocol=https;rev=02c2bb2980bf307aa654d908f3d54ce2c01d2d92;branch=beta-release"
+
+S = "${WORKDIR}/git"
+
+MAKE_TARGETS = "-C ${STAGING_KERNEL_DIR} M=${WORKDIR}/git MODULE_GIT_REPOSITORY_DIR=${METADIR}/meta-agl-devel"
+MODULES_INSTALL_TARGET = "-C ${STAGING_KERNEL_DIR} M=${WORKDIR}/git modules_install"
+
diff --git a/meta-egvirt/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-egvirt/recipes-kernel/linux/linux-yocto-dev.bbappend
index 750be259..f1388a33 100644
--- a/meta-egvirt/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/meta-egvirt/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -12,3 +12,8 @@ SRC_URI:append = " \
file://virtio_bt.cfg \
file://0002-Bluetooth-virtio_bt-fix-device-removal.patch \
"
+
+# virtio loopback
+SRC_URI += " \
+ file://virtio_loopback.cfg \
+"
diff --git a/meta-egvirt/recipes-kernel/linux/linux-yocto/virtio_loopback.cfg b/meta-egvirt/recipes-kernel/linux/linux-yocto/virtio_loopback.cfg
new file mode 100644
index 00000000..d20575e4
--- /dev/null
+++ b/meta-egvirt/recipes-kernel/linux/linux-yocto/virtio_loopback.cfg
@@ -0,0 +1,2 @@
+CONFIG_HW_RANDOM_VIRTIO=m
+CONFIG_VIRTIO_INPUT=y
diff --git a/meta-egvirt/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-egvirt/recipes-kernel/linux/linux-yocto_%.bbappend
index d646f535..b75875ba 100644
--- a/meta-egvirt/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/meta-egvirt/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -11,3 +11,8 @@ SRC_URI += " \
file://virtio_bt.cfg \
file://0002-Bluetooth-virtio_bt-fix-device-removal.patch \
"
+
+# virtio loopback
+SRC_URI += " \
+ file://virtio_loopback.cfg \
+"