summaryrefslogtreecommitdiffstats
path: root/meta-egvirt
diff options
context:
space:
mode:
authorMichele Paolino <m.paolino@virtualopensystems.com>2017-08-08 11:14:09 +0200
committerMichele Paolino <m.paolino@virtualopensystems.com>2017-08-10 11:27:30 +0200
commit62b410682cb607db6830a9a7e7edc86e300f2fc3 (patch)
treebbf1335a9397ffcfa012fc749886bf2fd3d8fe6a /meta-egvirt
parent83bd7c56540444bfcf8ddb3819a5ec77934473e1 (diff)
Install qemu and create agl-egvirt machine feature
qemu is the userspace emulator needed to run KVM virtual machines. This patch adds a bbappend for qemu in the meta-egvirt layer, and includes it in the packages to be installed in the AGL distro. To do this, the new agl-egvirt machine feature has been created and is used to enable virtualization specific extensions created by the EG-VIRT group for AGL. In order to reduce its impact on the AGL image, the qemu targets have been limited to aarch64 and x86_64 only. Changelog v2: - agl-egvirt added to MACHINE_FEATURES - use of class_target to not create conflict by the QEMU version used in the SDK and the one used by KVM - README file updated accordingly Bug-AGL: SPEC-718 Change-Id: I27288382443ba2bfe14d574ade2e691a63da145d Signed-off-by: Michele Paolino <m.paolino@virtualopensystems.com>
Diffstat (limited to 'meta-egvirt')
-rw-r--r--meta-egvirt/README.md10
-rw-r--r--meta-egvirt/conf/include/agl_egvirt.inc2
-rw-r--r--meta-egvirt/recipes-core/qemu/qemu_2.%.bbappend1
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-egvirt/README.md b/meta-egvirt/README.md
index b6ba7a6a..15235ab9 100644
--- a/meta-egvirt/README.md
+++ b/meta-egvirt/README.md
@@ -13,6 +13,16 @@ depending on their availability and on the community interest.
Maintainers:
Michele Paolino <m.paolino@virtualopensystems.com>
+
+How to enable agl virtualization feature
+------------------------------------------------------
+In order to enable the agl virtualization features (agl-egvirt),
+each supported board needs to add in one of its configuration
+files (see for instance meta-agl/meta-agl-bsp/conf/include)
+the following line:
+
+MACHINE_FEATURES += "agl-egvirt"
+
References
------------------------------------------------------
EG-VIRT wikipage:
diff --git a/meta-egvirt/conf/include/agl_egvirt.inc b/meta-egvirt/conf/include/agl_egvirt.inc
new file mode 100644
index 00000000..b4df5d8b
--- /dev/null
+++ b/meta-egvirt/conf/include/agl_egvirt.inc
@@ -0,0 +1,2 @@
+OVERRIDES .= "${@bb.utils.contains('MACHINE_FEATURES', 'agl-egvirt', ':aglegvirt', '', d)}"
+IMAGE_INSTALL_append_aglegvirt = " qemu "
diff --git a/meta-egvirt/recipes-core/qemu/qemu_2.%.bbappend b/meta-egvirt/recipes-core/qemu/qemu_2.%.bbappend
new file mode 100644
index 00000000..1a6a98b7
--- /dev/null
+++ b/meta-egvirt/recipes-core/qemu/qemu_2.%.bbappend
@@ -0,0 +1 @@
+QEMU_TARGETS_class-target_aglegvirt = " aarch64 x86_64"