summaryrefslogtreecommitdiffstats
path: root/meta-egvirt
diff options
context:
space:
mode:
authorVasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>2020-10-03 21:43:54 +0300
committerVasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>2020-11-06 08:27:45 +0200
commit916e4dd97804d410d3cdcc22ae12fc566aa41774 (patch)
tree26a24593e9b2a7135a59c1b17c0f89e1c5036a43 /meta-egvirt
parent26dc09e04a625028ebf45bc3acd40ce43b2e812c (diff)
Return meta-egvirt layer for AGL virtualization
At the moment, this layer is planned to be used to implement virtio-aarch64 machine intended to be used in virtualized environments. This partially reverts commit: 0abaf1d Cleanup of meta-agl-devel for HH Bug-AGL: SPEC-3668 Change-Id: I73f140d7941edaad8e482f143bfcc296823d21b7 Signed-off-by: Vasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>
Diffstat (limited to 'meta-egvirt')
-rw-r--r--meta-egvirt/COPYING.MIT17
-rw-r--r--meta-egvirt/README.md28
-rw-r--r--meta-egvirt/conf/layer.conf16
3 files changed, 61 insertions, 0 deletions
diff --git a/meta-egvirt/COPYING.MIT b/meta-egvirt/COPYING.MIT
new file mode 100644
index 00000000..fb950dc6
--- /dev/null
+++ b/meta-egvirt/COPYING.MIT
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/meta-egvirt/README.md b/meta-egvirt/README.md
new file mode 100644
index 00000000..dee4f843
--- /dev/null
+++ b/meta-egvirt/README.md
@@ -0,0 +1,28 @@
+Virtualization support (meta-egvirt)
+======================================================
+
+meta-egvirt is the AGL Virtualization Expert Group (EG-VIRT) layer. It aims to
+design, test, implement and assess virtualization technologies (containers,
+hypervisors, system partitioners and other solutions) for AGL ARMv8 and Intel
+platforms.
+
+From the software side, VirtIO standards are considered as a common framework to
+provide virtualized devices. Developing standardized solutions reduces community
+fragmentation and increases freedom to choose hypervisor and SoC.
+
+From the hardware side, the primary target of such work is for the time being
+the Reference Hardware development platform which uses the Renesas R-Car H3 SoC
+(ARMv8). Other solutions will be added in future, depending on their
+availability and on the community interest.
+
+Maintainers:
+ Mikhail Golubev <mikhail.golubev@opensynergy.com>
+
+References
+------------------------------------------------------
+EG-VIRT wikipage:
+ https://wiki.automotivelinux.org/eg-virt
+EG-VIRT meetings:
+ https://wiki.automotivelinux.org/eg-virt-meetings
+EG-RHSA wikipage:
+ https://wiki.automotivelinux.org/eg-rhsa
diff --git a/meta-egvirt/conf/layer.conf b/meta-egvirt/conf/layer.conf
new file mode 100644
index 00000000..5c4d8e67
--- /dev/null
+++ b/meta-egvirt/conf/layer.conf
@@ -0,0 +1,16 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "egvirt"
+BBFILE_PATTERN_egvirt = "^${LAYERDIR}/"
+BBFILE_PRIORITY_egvirt = "6"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_egvirt = "1"
+LAYERSERIES_COMPAT_egvirt = "dunfell"
+
+LAYERDEPENDS_egvirt = "core"