summaryrefslogtreecommitdiffstats
path: root/meta-oem-extra-libs/recipes-support
diff options
context:
space:
mode:
authortte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2016-10-20 16:17:50 +0900
committertte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2016-11-02 17:22:04 +0900
commit2c595497e43fadd83ea155f632ba69a31fe923fa (patch)
treefb95e43c8bff0f65da10a43204501181503ab486 /meta-oem-extra-libs/recipes-support
parentf25d5b743034c65add42639148ff16563a62b044 (diff)
Add software packages for oem needs library
These recipes is support software packages for oem needs. The librarys include: boost, fixesproto, imagemagick, iptables, Xorg-macros zlib, eglibc(glibc), libcurl, libgif, libneon, mongoose fuse, protocol buffers, bsdiff, module-init-tools libcroco, libtiff, librsvg, libpcap, libtar You can add these librarys by feature 'agl-oem-extra-libs' source meta-agl/scripts/aglsetup.sh -m porter agl-demo [agl-appfw-smack] [agl-devel] [agl-netboot] agl-oem-extra-libs v2[jsmoeller]: - change to ImageMagick recipe (generalize configure append and add dependency) - readd libtar with tarball taken from debian as original git is n/a v3[tte_zheng_wenlong] - add libtar and libtar-dev in packagegroup-ivi-common-core-os-commonlibs.bbappend - modify README.md to explain build command. v4[tte_zheng_wenlong] - modify mongoose license from GPLv2 to MIT. - delete [] for agl-oem-extra-libs for README.md Change-Id: I1f9d2f1c023f332d528918c3f730ee0360a1f497 Signed-off-by: tte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-oem-extra-libs/recipes-support')
-rw-r--r--meta-oem-extra-libs/recipes-support/imagemagick/imagemagick_%.bbappend2
-rw-r--r--meta-oem-extra-libs/recipes-support/mongodb/mongoose_git.bb60
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-oem-extra-libs/recipes-support/imagemagick/imagemagick_%.bbappend b/meta-oem-extra-libs/recipes-support/imagemagick/imagemagick_%.bbappend
new file mode 100644
index 00000000..2fa9538e
--- /dev/null
+++ b/meta-oem-extra-libs/recipes-support/imagemagick/imagemagick_%.bbappend
@@ -0,0 +1,2 @@
+DEPENDS_append = " libxml2 libxml2-native"
+EXTRA_OECONF_append = " --with-xml"
diff --git a/meta-oem-extra-libs/recipes-support/mongodb/mongoose_git.bb b/meta-oem-extra-libs/recipes-support/mongodb/mongoose_git.bb
new file mode 100644
index 00000000..35fd3f29
--- /dev/null
+++ b/meta-oem-extra-libs/recipes-support/mongodb/mongoose_git.bb
@@ -0,0 +1,60 @@
+SUMMARY = "mongoose"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README.md;beginline=302;endline=321;md5=dbdda6492d8f693c50356f55d30cbb5e \
+ "
+
+PV = "4.6.1+git${SRCPV}"
+SRCREV = "4913935d321efbf2b6dccc4b4ba1679a73d5bd08"
+SRC_URI = "git://github.com/Automattic/mongoose.git;protocol=git;branch=master \
+ "
+RDEPENDS_${PN} += "mongodb \
+ nodejs \
+ "
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} = " \
+ ${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/* \
+ "
+
+do_configure() {
+}
+
+do_compile() {
+}
+
+install_file_directory() {
+ for obj in $1/*; do
+ fname=`basename $obj`
+ if ! [ -e $2 ]; then
+ install -d 0644 $2
+ fi
+ if [ -f $1/$fname ]; then
+ install -m 0644 $1/$fname $2
+ elif [ -d $1/$fname ]; then
+ if ! [ -e $2/$fname ]; then
+ install -d 0644 $2/$fname
+ fi
+ install_file_directory $1/$fname $2/$fname
+ fi
+ done
+}
+
+do_install() {
+ install -d ${D}${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/
+
+ install -m 0644 ${S}/CONTRIBUTING.md ${D}${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/
+ install -m 0644 ${S}/History.md ${D}${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/
+ install -m 0644 ${S}/index.js ${D}${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/
+ install -m 0644 ${S}/README.md ${D}${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/
+ install -m 0644 ${S}/package.json ${D}${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/
+ install -m 0644 ${S}/release-items.md ${D}${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/
+ install -m 0644 ${S}/static.js ${D}${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/
+ install -m 0644 ${S}/website.js ${D}${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/
+
+ install_file_directory ${S}/examples ${D}${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/examples/
+ install_file_directory ${S}/lib ${D}${exec_prefix}/lib/node_modules/npm/node_modules/mongoose/lib/
+
+# sed -i '/devDependencies/a\ \ \ \ \"mongoose\"\:\ \"\~4\.6\.2\"\,' ${D}${exec_prefix}/lib/node_modules/npm/package.json
+}
+