summaryrefslogtreecommitdiffstats
path: root/meta-oem-production-readiness/meta-agl-basesystem/recipes-core
diff options
context:
space:
mode:
authorRiku Nomoto <riku.nomoto@woven-planet.global>2020-11-26 23:09:02 +0900
committerRiku Nomoto <riku.nomoto@woven-planet.global>2021-01-12 15:29:21 +0900
commita0197682c5b732a81aeb3c2459adfc8d45f969b1 (patch)
tree61caf0f6aa5369a6abe08857ce49c7012f48d57d /meta-oem-production-readiness/meta-agl-basesystem/recipes-core
parentaf25a3b5a46c74124f1fb99e7157cc6aea879a5c (diff)
oem-pr-bs: add core services and libraries
This is the second commit of agl-basesystem. IPC/RPC library group binding each modules v14 (jsmoeller): update BASESYSTEM_REVISION to fix libinput-hal build v16 (jsmoeller): update BASESYSTEM_REVISION v17 (taniakwa): fix os-rpclibrary-tool-native build - fix invalid path to LICENSE to use devtool - fix error when rebuild (clean generated files first) v19 (nomoto): fix to set host only tool in class-native v20 (nomoto): update subpath, branch and S to make recipes simple v21 (nomoto): fix EXTRA_OEMAKE to set default value v25 (nomoto): change mail address and author v29 (nomoto): remove agl-basesystem-hal.bbclass Bug-AGL: SPEC-3670 Signed-off-by: Riku Nomoto <riku.nomoto@woven-planet.global> Change-Id: I5da43003d8a976912d183474aea884ec1b81a708
Diffstat (limited to 'meta-oem-production-readiness/meta-agl-basesystem/recipes-core')
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-basefiles/agl-basefiles_1.0.0.bb27
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-core/ns-frameworkunified/ns-frameworkunified-library_1.0.0.bb30
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-core/ns-frameworkunified/ns-frameworkunified_1.0.0.bb32
3 files changed, 89 insertions, 0 deletions
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-basefiles/agl-basefiles_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-basefiles/agl-basefiles_1.0.0.bb
new file mode 100644
index 00000000..27b2cae0
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-basefiles/agl-basefiles_1.0.0.bb
@@ -0,0 +1,27 @@
+SUMMARY = "base-files for AGL software"
+DESCRIPTION = "install base-files to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/agl-basefiles"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${includedir}/basesystem
+ install -m 644 -D ${S}/include/* ${D}${includedir}/basesystem/
+}
+
+do_install_class-native() {
+ install -d ${D}${bindir}
+ install -m 755 -D ${S}/bin/launch_xml2cfg.sh ${D}${bindir}/
+}
+
+RDEPENDS_${PN} += "bash"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/ns-frameworkunified/ns-frameworkunified-library_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/ns-frameworkunified/ns-frameworkunified-library_1.0.0.bb
new file mode 100644
index 00000000..baaa431e
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/ns-frameworkunified/ns-frameworkunified-library_1.0.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "ns-frameworkunified library for AGL software"
+DESCRIPTION = "ns-frameworkunified library to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " \
+ ns-loglibrary \
+ libxml2 \
+ ns-frameworkunified \
+"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/service/native/framework_unified"
+
+inherit agl-basesystem-common
+
+BSMAKE_FILE = "Makefile.library"
+
+FILES_${PN} += " \
+ ${libdir}/* \
+"
+
+RDEPENDS_${PN} += " \
+ os-posixbasedos001legacylibrary \
+ ns-loglibrary \
+ ns-commonlibrary \
+"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/ns-frameworkunified/ns-frameworkunified_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/ns-frameworkunified/ns-frameworkunified_1.0.0.bb
new file mode 100644
index 00000000..25ac7b90
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/ns-frameworkunified/ns-frameworkunified_1.0.0.bb
@@ -0,0 +1,32 @@
+SUMMARY = "ns-frameworkunified for AGL software"
+DESCRIPTION = "ns-frameworkunified to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " \
+ os-posixbasedos001legacylibrary \
+ ns-loglibrary \
+ ns-commonlibrary \
+ boost \
+"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/service/native/framework_unified"
+
+inherit agl-basesystem-common
+
+BSMAKE_FILE = "Makefile.client"
+
+FILES_${PN} += " \
+ ${libdir}/* \
+"
+
+RDEPENDS_${PN} += " \
+ os-posixbasedos001legacylibrary \
+ ns-loglibrary \
+ ns-commonlibrary \
+ ns-frameworkunified-library \
+"