summaryrefslogtreecommitdiffstats
path: root/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-12-19 16:13:15 -0500
committerScott Murray <scott.murray@konsulko.com>2020-12-21 09:41:02 -0500
commitaf25a3b5a46c74124f1fb99e7157cc6aea879a5c (patch)
tree5a6ba2e217d11d6145f6a00226715e520a441d8d /meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb
parent4e5b9be85750852559f22b0b3493e6074b8f4fac (diff)
meta-agl-basesystem: add libxml-xpath-perl
Add libxml-xpath-perl recipe and recipes for its required dependencies libscalar-list-utils-perl and libpath-tiny-perl. This should enable using the xpath utility in the basesystem build by DEPENDing on libxml-xpath-perl-native. Note that the libscalar-list-utils-perl recipe has been adapted from the one present in meta-cpan (https://github.com/meta-cpan/meta-cpan) as of commit 2f6ecfa. This was viewed as preferable to pulling in meta-cpan as an AGL dependency. Additionally, the recipe has been updated to enable ptest support, and all tests have been confirmed to pass. The same is true of the libxml-xpath-perl and libpath-tiny-perl ptests. Bug-AGL: SPEC-3670 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Icd25cbb4498636c5a6a384818535e3c3372b5b29
Diffstat (limited to 'meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb')
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb
new file mode 100644
index 00000000..3f130550
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb
@@ -0,0 +1,45 @@
+SUMMARY = "Perl modules for parsing and evaluating XPath statements"
+HOMEPAGE = "https://metacpan.org/release/XML-XPath"
+SECTION = "libs"
+LICENSE = "Artistic-2.0 & (Artistic-1.0 | GPL-1.0+)"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b5714f72ee964281c4a38b1f0db4213e \
+ file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
+ file://${COMMON_LICENSE_DIR}/GPL-1.0;md5=e9e36a9de734199567a4d769498f743d"
+
+SRC_URI = "https://cpan.metacpan.org/authors/id/M/MA/MANWAR/XML-XPath-${PV}.tar.gz \
+ file://adjust-load-test-for-ptest.patch"
+SRC_URI[sha256sum] = "1cc9110705165dc09dd09974dd7c0b6709c9351d6b6b1cef5a711055f891dd0f"
+
+S = "${WORKDIR}/XML-XPath-${PV}"
+
+inherit cpan ptest-perl
+
+do_install_append_class-native() {
+ # Fix xpath script shebang to work inside native environment
+ sed -i 's|#!.*/perl|#!/usr/bin/env perl|' ${D}${bindir}/xpath
+}
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/examples
+ install -m 0644 ${S}/examples/test.xml ${D}${PTEST_PATH}/examples/
+}
+
+RDEPENDS_${PN} += " \
+ perl-module-carp \
+ perl-module-data-dumper \
+ perl-module-file-spec \
+ perl-module-io-file \
+ perl-module-open \
+ perl-module-overload \
+ perl-module-perlio \
+ perl-module-perlio-encoding \
+ perl-module-utf8 \
+ libxml-parser-perl \
+ libscalar-list-utils-perl \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ libpath-tiny-perl \
+"
+
+BBCLASSEXTEND = "native"