summaryrefslogtreecommitdiffstats
path: root/meta-oem-production-readiness/meta-agl-basesystem/recipes-support
diff options
context:
space:
mode:
authorRiku Nomoto <riku.nomoto@woven-planet.global>2020-11-26 23:09:02 +0900
committerRiku Nomoto <riku.nomoto@woven-planet.global>2021-01-12 15:29:21 +0900
commita0197682c5b732a81aeb3c2459adfc8d45f969b1 (patch)
tree61caf0f6aa5369a6abe08857ce49c7012f48d57d /meta-oem-production-readiness/meta-agl-basesystem/recipes-support
parentaf25a3b5a46c74124f1fb99e7157cc6aea879a5c (diff)
oem-pr-bs: add core services and libraries
This is the second commit of agl-basesystem. IPC/RPC library group binding each modules v14 (jsmoeller): update BASESYSTEM_REVISION to fix libinput-hal build v16 (jsmoeller): update BASESYSTEM_REVISION v17 (taniakwa): fix os-rpclibrary-tool-native build - fix invalid path to LICENSE to use devtool - fix error when rebuild (clean generated files first) v19 (nomoto): fix to set host only tool in class-native v20 (nomoto): update subpath, branch and S to make recipes simple v21 (nomoto): fix EXTRA_OEMAKE to set default value v25 (nomoto): change mail address and author v29 (nomoto): remove agl-basesystem-hal.bbclass Bug-AGL: SPEC-3670 Signed-off-by: Riku Nomoto <riku.nomoto@woven-planet.global> Change-Id: I5da43003d8a976912d183474aea884ec1b81a708
Diffstat (limited to 'meta-oem-production-readiness/meta-agl-basesystem/recipes-support')
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-commonlibrary/ns-commonlibrary_1.0.0.bb18
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-loglibrary/ns-loglibrary_1.0.0.bb18
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-eventlibrary/os-eventlibrary_1.0.0.bb25
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-posixbasedos001legacylibrary/os-posixbasedos001legacylibrary_1.0.0.bb18
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-rpclibrary/os-rpclibrary-tool_1.0.0.bb29
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-rpclibrary/os-rpclibrary_1.0.0.bb29
6 files changed, 137 insertions, 0 deletions
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-commonlibrary/ns-commonlibrary_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-commonlibrary/ns-commonlibrary_1.0.0.bb
new file mode 100644
index 00000000..1fdf7efe
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-commonlibrary/ns-commonlibrary_1.0.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "ns-commonlibrary for AGL software"
+DESCRIPTION = "ns-commonlibrary to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/service/native/common_library"
+
+inherit agl-basesystem-common
+
+BSMAKE_FILE = "Makefile.client"
+
+FILES_${PN} += " \
+ ${libdir}/* \
+"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-loglibrary/ns-loglibrary_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-loglibrary/ns-loglibrary_1.0.0.bb
new file mode 100644
index 00000000..c59ba5a6
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-loglibrary/ns-loglibrary_1.0.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "ns-loglibrary for AGL software"
+DESCRIPTION = "ns-loglibrary to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/service/native/log_library"
+
+inherit agl-basesystem-common
+
+BSMAKE_FILE = "Makefile.client"
+
+FILES_${PN} += " \
+ ${libdir}/* \
+"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-eventlibrary/os-eventlibrary_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-eventlibrary/os-eventlibrary_1.0.0.bb
new file mode 100644
index 00000000..8dc4b291
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-eventlibrary/os-eventlibrary_1.0.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "os-eventlibrary for AGL software"
+DESCRIPTION = "os-eventlibrary to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " \
+ evklib-headers \
+"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/service/other/event_library"
+
+inherit agl-basesystem-common
+
+BSMAKE_FILE = "Makefile.client"
+
+FILES_${PN} += " \
+ ${libdir}/* \
+"
+RDEPENDS_${PN} += " \
+ kernel-module-evklib \
+"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-posixbasedos001legacylibrary/os-posixbasedos001legacylibrary_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-posixbasedos001legacylibrary/os-posixbasedos001legacylibrary_1.0.0.bb
new file mode 100644
index 00000000..ff878356
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-posixbasedos001legacylibrary/os-posixbasedos001legacylibrary_1.0.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "os-posixbasedos001legacylibrary for AGL software"
+DESCRIPTION = "os-posixbasedos001legacylibrary to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/service/other/posix_based_os001_legacy_library"
+
+inherit agl-basesystem-common
+
+BSMAKE_FILE = "Makefile.client"
+
+FILES_${PN} += " \
+ ${libdir}/* \
+"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-rpclibrary/os-rpclibrary-tool_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-rpclibrary/os-rpclibrary-tool_1.0.0.bb
new file mode 100644
index 00000000..573207ac
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-rpclibrary/os-rpclibrary-tool_1.0.0.bb
@@ -0,0 +1,29 @@
+SUMMARY = "librpc tools for AGL software"
+DESCRIPTION = "install librpc tool"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " \
+ agl-basefiles-native \
+ bison-native \
+"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/service/other/rpc_library/tool"
+
+do_compile_prepend () {
+ oe_runmake clean
+}
+
+do_install () {
+ install -D -m 755 ${S}/rpc_apidef ${D}${bindir}/rpc_apidef
+}
+
+FILES_${PN} += " \
+ ${bindir}/rpc_apidef \
+"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-rpclibrary/os-rpclibrary_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-rpclibrary/os-rpclibrary_1.0.0.bb
new file mode 100644
index 00000000..95631dcb
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/os-rpclibrary/os-rpclibrary_1.0.0.bb
@@ -0,0 +1,29 @@
+SUMMARY = "os-rpclibrary for AGL software"
+DESCRIPTION = "os-rpclibrary to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " \
+ ns-commonlibrary \
+ ns-loglibrary \
+ bison-native \
+"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/service/other/rpc_library"
+
+inherit agl-basesystem-common
+
+BSMAKE_FILE = "Makefile.client"
+
+FILES_${PN} += " \
+ /usr/lib/basesystem/librpc.so \
+"
+
+RDEPENDS_${PN} += " \
+ ns-commonlibrary \
+ ns-loglibrary \
+"