summaryrefslogtreecommitdiffstats
path: root/meta-oem-production-readiness
diff options
context:
space:
mode:
authorRiku Nomoto <riku.nomoto@woven-planet.global>2020-12-15 13:52:16 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-14 16:29:30 +0000
commit5238d28c0c8924e6d441337e169458c18f3cc6a2 (patch)
tree7729b538592befabaa678fbd22eeb3a83788bee4 /meta-oem-production-readiness
parentd1de3f2d01e1a48c7d2b9620adbbb98ee62e7357 (diff)
oem-pr-bs: add various HAL libraries
This is the fourth commit of agl-basesystem. These Basesystem HAL implementation are sample. v16 (jsmoeller): restored commit which was squashed in v15 v22 (nomoto): change mail address and author v26 (nomoto): make hal recipes inherit bshalmake Bug-AGL: SPEC-3670 Signed-off-by: Riku Nomoto <riku.nomoto@woven-planet.global> Change-Id: Ib6ff58e667635725d962d1548bef03950e0a0d22
Diffstat (limited to 'meta-oem-production-readiness')
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/classes/bshalmake.bbclass2
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libboot-hal/libboot-hal_1.0.0.bb17
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libcan-hal/libcan-hal_1.0.0.bb17
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libclock-hal/libclock-hal_1.0.0.bb17
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libdeck-hal/libdeck-hal_1.0.0.bb17
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libinput-hal/libinput-hal_1.0.0.bb21
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libpower-hal/libpower-hal_1.0.0.bb17
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libsecurity-hal/libsecurity-hal_1.0.0.bb17
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libsoctemperature-hal/libsoctemperature-hal_1.0.0.bb17
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libusb-hal/libusb-hal_1.0.0.bb17
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libvehicle-hal/libvehicle-hal_1.0.0.bb17
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libvideo-in-hal/libvideo-in-hal_1.0.0.bb17
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem-hal.bb15
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem.bb2
14 files changed, 207 insertions, 3 deletions
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/classes/bshalmake.bbclass b/meta-oem-production-readiness/meta-agl-basesystem/classes/bshalmake.bbclass
index bd2fd9c1..5f05dda9 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/classes/bshalmake.bbclass
+++ b/meta-oem-production-readiness/meta-agl-basesystem/classes/bshalmake.bbclass
@@ -1,6 +1,6 @@
# base_do_install under poky's base.bbclass is empty so definition is needed.
bshalmake_do_install (){
- oe_runmake install
+ oe_runmake DESTDIR=${D} install
install -d ${D}${includedir}/basesystem
install -D -m 644 ${S}/hal_api/*.h ${D}${includedir}/basesystem
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libboot-hal/libboot-hal_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libboot-hal/libboot-hal_1.0.0.bb
new file mode 100644
index 00000000..9cb14281
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libboot-hal/libboot-hal_1.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "libboot_hal for AGL software"
+DESCRIPTION = "install libboot_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/hal/boot_hal"
+
+inherit bshalmake
+
+HAL_NAME = "boot_hal"
+FILES_${PN} += "${libdir}/lib${HAL_NAME}.so"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libcan-hal/libcan-hal_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libcan-hal/libcan-hal_1.0.0.bb
new file mode 100644
index 00000000..559d42a2
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libcan-hal/libcan-hal_1.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "libcan_hal for AGL software"
+DESCRIPTION = "install libcan_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/hal/can_hal"
+
+inherit bshalmake
+
+HAL_NAME = "can_hal"
+FILES_${PN} += "${libdir}/basesystem/lib${HAL_NAME}.so"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libclock-hal/libclock-hal_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libclock-hal/libclock-hal_1.0.0.bb
new file mode 100644
index 00000000..3599b2a3
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libclock-hal/libclock-hal_1.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "libclock_hal for AGL software"
+DESCRIPTION = "install libclock_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/hal/clock_hal"
+
+inherit bshalmake
+
+HAL_NAME = "clock_hal"
+FILES_${PN} += "${libdir}/lib${HAL_NAME}.so"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libdeck-hal/libdeck-hal_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libdeck-hal/libdeck-hal_1.0.0.bb
new file mode 100644
index 00000000..059641da
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libdeck-hal/libdeck-hal_1.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "libdeck_hal for AGL software"
+DESCRIPTION = "install libdeck_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/hal/deck_hal"
+
+inherit bshalmake
+
+HAL_NAME = "deck_hal"
+FILES_${PN} += "${libdir}/lib${HAL_NAME}.so"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libinput-hal/libinput-hal_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libinput-hal/libinput-hal_1.0.0.bb
new file mode 100644
index 00000000..495f6394
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libinput-hal/libinput-hal_1.0.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "libinput_hal for AGL software"
+DESCRIPTION = "install libinput_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " \
+ ns-frameworkunified\
+ drm \
+ udev \
+"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/hal/input_hal"
+
+inherit bshalmake
+
+HAL_NAME = "input_hal"
+FILES_${PN} += "${libdir}/lib${HAL_NAME}.so"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libpower-hal/libpower-hal_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libpower-hal/libpower-hal_1.0.0.bb
new file mode 100644
index 00000000..ebf34a08
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libpower-hal/libpower-hal_1.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "libpower_hal for AGL software"
+DESCRIPTION = "install libpower_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/hal/power_hal"
+
+inherit bshalmake
+
+HAL_NAME = "power_hal"
+FILES_${PN} += "${libdir}/lib${HAL_NAME}.so"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libsecurity-hal/libsecurity-hal_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libsecurity-hal/libsecurity-hal_1.0.0.bb
new file mode 100644
index 00000000..b76cf117
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libsecurity-hal/libsecurity-hal_1.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "libsecurity_hal for AGL software"
+DESCRIPTION = "install libsecurity_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/hal/security_hal"
+
+inherit bshalmake
+
+HAL_NAME = "security_hal"
+FILES_${PN} += "${libdir}/lib${HAL_NAME}.so"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libsoctemperature-hal/libsoctemperature-hal_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libsoctemperature-hal/libsoctemperature-hal_1.0.0.bb
new file mode 100644
index 00000000..f24c5d7e
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libsoctemperature-hal/libsoctemperature-hal_1.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "libsoc_temperature-hal for AGL software"
+DESCRIPTION = "install libsoc_temperature-hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/hal/soc_temperature_hal"
+
+inherit bshalmake
+
+HAL_NAME = "soc_temperature_hal"
+FILES_${PN} += "${libdir}/lib${HAL_NAME}.so"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libusb-hal/libusb-hal_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libusb-hal/libusb-hal_1.0.0.bb
new file mode 100644
index 00000000..ed4e7b19
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libusb-hal/libusb-hal_1.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "libusb_hal for AGL software"
+DESCRIPTION = "install libusb_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/hal/usb_hal"
+
+inherit bshalmake
+
+HAL_NAME = "usb_hal"
+FILES_${PN} += "${libdir}/lib${HAL_NAME}.so"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libvehicle-hal/libvehicle-hal_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libvehicle-hal/libvehicle-hal_1.0.0.bb
new file mode 100644
index 00000000..17232dd6
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libvehicle-hal/libvehicle-hal_1.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "libvehicle_hal for AGL software"
+DESCRIPTION = "install libvehicle_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/hal/vehicle_hal"
+
+inherit bshalmake
+
+HAL_NAME = "vehicle_hal"
+FILES_${PN} += "${libdir}/lib${HAL_NAME}.so"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libvideo-in-hal/libvideo-in-hal_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libvideo-in-hal/libvideo-in-hal_1.0.0.bb
new file mode 100644
index 00000000..676809ef
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-hal/libvideo-in-hal/libvideo-in-hal_1.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "libvideo_in_hal for AGL software"
+DESCRIPTION = "install libvideo_in_hal to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/hal/video_in_hal"
+
+inherit bshalmake
+
+HAL_NAME = "video_in_hal"
+FILES_${PN} += "${libdir}/lib${HAL_NAME}.so"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem-hal.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem-hal.bb
index 7afd629f..3d043f88 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem-hal.bb
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem-hal.bb
@@ -4,5 +4,18 @@ LICENSE = "Apache-2.0"
inherit packagegroup
PACKAGES = "\
- packagegroup-agl-basesystem-hal \
+ packagegroup-bshalmake \
+"
+RDEPENDS_${PN} += " \
+ libboot-hal \
+ libcan-hal \
+ libclock-hal \
+ libdeck-hal \
+ libinput-hal \
+ libpower-hal \
+ libsecurity-hal \
+ libsoctemperature-hal \
+ libusb-hal \
+ libvehicle-hal \
+ libvideo-in-hal \
"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem.bb
index 2f13587f..85614c03 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem.bb
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem.bb
@@ -17,5 +17,5 @@ RDEPENDS_${PN} += "\
packagegroup-agl-basesystem-core \
packagegroup-agl-basesystem-apis \
packagegroup-agl-basesystem-service \
- packagegroup-agl-basesystem-hal \
+ packagegroup-bshalmake \
"