summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/dynamic-layers/meta-agl-demo
diff options
context:
space:
mode:
authoramanarora_09 <aman.arora9848@gmail.com>2023-03-28 22:27:17 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-03-30 16:27:26 +0200
commit490f70d3150cd0f92e89d24472ac81c77b99dbf9 (patch)
tree3145f36c5bc4bbcdd1e97283993bcfe5858f4a35 /meta-offline-voice-agent/dynamic-layers/meta-agl-demo
parent9a991da4d017ff05f291316b6ead7be6bd5ded14 (diff)
Change-Id: I31ac4adc874a206e6e598ba116523ecc7eb99fc9 Signed-off-by: amanarora_09 <aman.arora9848@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/dynamic-layers/meta-agl-demo')
-rw-r--r--meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-demo/flutter-vosk-demo/flutter-vosk-demo_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-demo/flutter-vosk-demo/flutter-vosk-demo_git.bb b/meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-demo/flutter-vosk-demo/flutter-vosk-demo_git.bb
new file mode 100644
index 00000000..29721ba6
--- /dev/null
+++ b/meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-demo/flutter-vosk-demo/flutter-vosk-demo_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Flutter VOSK Demo"
+DESCRIPTION = "A Flutter based Offline Speech Recognition Demo Application using the VOSK API."
+
+HOMEPAGE = "https://github.com/amanarora9848/voicerecognizer-gst-grpc.git"
+
+BUGTRACKER = "https://github.com/amanarora9848/voicerecognizer-gst-grpc.git"
+
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=13e8863a069f2c314d9251336e4afcbf"
+
+
+SRC_URI = "git://github.com/amanarora9848/voicerecognizer-gst-grpc.git;protocol=https;branch=master"
+
+SRCREV = "${AUTOREV}"
+S = "${WORKDIR}/git/app"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "flutter_vosk_demo"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "flutter_vosk_demo"
+AGL_APP_NAME = "VOSK-DEMO"
+
+RDEPENDS:${PN} = "vosk-grpc-custom-server"