summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/dynamic-layers
diff options
context:
space:
mode:
authoramanarora_09 <aman.arora9848@gmail.com>2023-03-28 22:27:17 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-08-08 20:38:17 +0200
commit8eb3ea414f84d3f28c14231ee8dda7876295e48e (patch)
treee11001ae1228054657ec475add06f1278d7a900a /meta-offline-voice-agent/dynamic-layers
parentfe8c4a516b3bff5f531caebd43c1f1ac137b9959 (diff)
Rework and update offline voice agent
This brings the voice agent to the state shown at AMM and EW. Change-Id: I31ac4adc874a206e6e598ba116523ecc7eb99fc9 Signed-off-by: amanarora_09 <aman.arora9848@gmail.com> Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-offline-voice-agent/dynamic-layers')
-rw-r--r--meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-demo/flutter-vosk-demo/flutter-vosk-demo_git.bb33
-rw-r--r--meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-platform/images/agl-demo-platform-voice.bb3
2 files changed, 33 insertions, 3 deletions
diff --git a/meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-demo/flutter-vosk-demo/flutter-vosk-demo_git.bb b/meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-demo/flutter-vosk-demo/flutter-vosk-demo_git.bb
new file mode 100644
index 00000000..78aef52e
--- /dev/null
+++ b/meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-demo/flutter-vosk-demo/flutter-vosk-demo_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Flutter VOSK Demo"
+DESCRIPTION = "A Flutter based Offline Speech Recognition Demo Application using the VOSK API."
+
+HOMEPAGE = "https://github.com/amanarora9848/voicerecognizer-gst-grpc.git"
+
+BUGTRACKER = "https://github.com/amanarora9848/voicerecognizer-gst-grpc.git"
+
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=13e8863a069f2c314d9251336e4afcbf"
+
+
+SRC_URI = "git://github.com/amanarora9848/voicerecognizer-gst-grpc.git;protocol=https;branch=master"
+
+SRCREV = "${AUTOREV}"
+S = "${WORKDIR}/git/app"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "flutter_vosk_demo"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "flutter_vosk_demo"
+AGL_APP_NAME = "VOSK-DEMO"
+
+RDEPENDS:${PN} = "vosk-grpc-server"
diff --git a/meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-platform/images/agl-demo-platform-voice.bb b/meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-platform/images/agl-demo-platform-voice.bb
deleted file mode 100644
index 6e39a7f0..00000000
--- a/meta-offline-voice-agent/dynamic-layers/meta-agl-demo/recipes-platform/images/agl-demo-platform-voice.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require recipes-platform/images/agl-ivi-demo-platform.bb
-
-IMAGE_INSTALL:append = "python3-vosk-api vosk vosk-server gcc make cmake autoconf automake gcc-c++ boost-dev" \ No newline at end of file