summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-assistant/voiceagent-app/agl-flutter-voiceassistant_git.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-10-11 18:46:48 +0500
committerMalik Talha <talhamalik727x@gmail.com>2023-10-11 18:49:01 +0500
commit57ffdf86d6deb808888bd86ab265c83f4d9f4094 (patch)
tree14dceb26b77452de2656926f3ad80e2bb5144e7a /meta-offline-voice-agent/recipes-assistant/voiceagent-app/agl-flutter-voiceassistant_git.bb
parent7b4a029168133bbf58c5dfe97e618badfe77b361 (diff)
Add recipes for voice agent service and app
Recipe files to compile the voice agent service and the flutter app, also add meta-tensorflow layer conf. Bug-AGL: SPEC-4906 Change-Id: I0e2eea863c95cd84d85d06194fbf01fcc64adb86 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-assistant/voiceagent-app/agl-flutter-voiceassistant_git.bb')
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-app/agl-flutter-voiceassistant_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/agl-flutter-voiceassistant_git.bb b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/agl-flutter-voiceassistant_git.bb
new file mode 100644
index 00000000..036e1fe6
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/agl-flutter-voiceassistant_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "AGL Voice Assistant"
+DESCRIPTION = "Offline voice assistant app designed for Automotive Grade Linux (AGL)."
+HOMEPAGE = "https://github.com/malik727/agl-flutter-voiceassistant"
+BUGTRACKER = "https://github.com/malik727/agl-flutter-voiceassistant/issues"
+SECTION = "graphics"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4202492ed9afcab3aaecc4a9ec32adb2"
+
+SRC_URI = "git://github.com/malik727/agl-flutter-voiceassistant.git;protocol=https;branch=main \
+ "
+
+SRCREV = "${AUTOREV}"
+S = "${WORKDIR}/git"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "agl_flutter_voiceassistant"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "agl_flutter_voiceassistant"
+AGL_APP_NAME = "AGL Voice Assistant" \ No newline at end of file