summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/numba/python3-numba_%.bbappend
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-python/numba/python3-numba_%.bbappend
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/numba/python3-numba_%.bbappend')
-rw-r--r--meta-offline-voice-agent/recipes-python/numba/python3-numba_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/numba/python3-numba_%.bbappend b/meta-offline-voice-agent/recipes-python/numba/python3-numba_%.bbappend
new file mode 100644
index 00000000..4bc055b5
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/numba/python3-numba_%.bbappend
@@ -0,0 +1,6 @@
+# remove the python3-llvmlite present in the meta-python-ai because it requires LLVM 15 to compile but AGL is using LLVM 18 rn
+RDEPENDS:${PN}:remove = "python3-llvmlite"
+
+# adding a precompile wheel for llvmlite-0.43.0 for x86_64 only
+RDEPENDS:${PN} += "llvmlite"
+