summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-aiogram_2.25.1.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
committerMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
commit7b4a029168133bbf58c5dfe97e618badfe77b361 (patch)
treeb8f63ff4baec31ba5ca7feb815869b30ccc653ba /meta-offline-voice-agent/recipes-python/python3-rasa/python3-aiogram_2.25.1.bb
parent713efdf66dca8e60c3db1e720a9bb2bd074c40f3 (diff)
Add dependencies for RASA framework
This adds the libraries for the RASA machine learning framework. Bug-AGL: SPEC-4856 Change-Id: I477b09cae8ff51e284b51238cb5940464ea57a51 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-aiogram_2.25.1.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-aiogram_2.25.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-aiogram_2.25.1.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-aiogram_2.25.1.bb
new file mode 100644
index 00000000..920f6f35
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-aiogram_2.25.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "aiogram is a modern and fully asynchronous framework for Telegram Bot API written in Python using asyncio"
+HOMEPAGE = "https://github.com/aiogram/aiogram"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=93cce29e93ddfef6ad50176fb23e6a5a"
+
+PYPI_PACKAGE = "aiogram"
+
+SRC_URI[md5sum] = "944ab87052eaa8fb16b6076750dfe1f1"
+SRC_URI[sha256sum] = "59ad78fc0ebbef1fd471c15778a4594b60117e0d7373bc2ce7bcd192074d527d"
+
+DEPENDS += " \
+ python3-magic-filter \
+ python3-aiohttp \
+ python3-aiofiles \
+ python3-certifi \
+ python3-pydantic \
+ python3-setuptools-native \
+"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-magic-filter \
+ python3-aiohttp \
+ python3-aiofiles \
+ python3-certifi \
+ python3-pydantic \
+"