summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-fire_0.5.0.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
committerMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
commit7b4a029168133bbf58c5dfe97e618badfe77b361 (patch)
treeb8f63ff4baec31ba5ca7feb815869b30ccc653ba /meta-offline-voice-agent/recipes-python/python3-rasa/python3-fire_0.5.0.bb
parent713efdf66dca8e60c3db1e720a9bb2bd074c40f3 (diff)
Add dependencies for RASA framework
This adds the libraries for the RASA machine learning framework. Bug-AGL: SPEC-4856 Change-Id: I477b09cae8ff51e284b51238cb5940464ea57a51 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-fire_0.5.0.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-fire_0.5.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-fire_0.5.0.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-fire_0.5.0.bb
new file mode 100644
index 00000000..49b2af50
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-fire_0.5.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Python Fire is a library for automatically generating command line interfaces (CLIs) from absolutely any Python object."
+HOMEPAGE = "https://github.com/google/python-fire"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ab892b2b62f951d424bdb712a72584cc"
+
+PYPI_PACKAGE = "fire"
+
+SRC_URI[md5sum] = "8b24d579bd2a1b344b4f9670fa49ebc8"
+SRC_URI[sha256sum] = "a6b0d49e98c8963910021f92bba66f65ab440da2982b78eb1bbf95a0a34aacc6"
+
+DEPENDS += "python3-six python3-termcolor"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-six python3-termcolor"