summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-randomname_0.1.5.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
committerMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
commit7b4a029168133bbf58c5dfe97e618badfe77b361 (patch)
treeb8f63ff4baec31ba5ca7feb815869b30ccc653ba /meta-offline-voice-agent/recipes-python/python3-rasa/python3-randomname_0.1.5.bb
parent713efdf66dca8e60c3db1e720a9bb2bd074c40f3 (diff)
Add dependencies for RASA framework
This adds the libraries for the RASA machine learning framework. Bug-AGL: SPEC-4856 Change-Id: I477b09cae8ff51e284b51238cb5940464ea57a51 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-randomname_0.1.5.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-randomname_0.1.5.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-randomname_0.1.5.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-randomname_0.1.5.bb
new file mode 100644
index 00000000..a68fb8a7
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-randomname_0.1.5.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Generate random names (adj-noun) like docker and github."
+HOMEPAGE = "https://github.com/beasteers/randomname"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=af47da9a50b5df42a6fb397386474144"
+
+SRC_URI = " \
+ git://github.com/beasteers/randomname;protocol=https;branch=main \
+ "
+
+PV = "0.1.5+git${SRCPV}"
+SRCREV = "1068e5107929d20b878b05d87363edfd5d83247d"
+S = "${WORKDIR}/git"
+
+DEPENDS += "python3-fire"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += "python3-fire"