summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-inference-agl_0.2.0.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-09-28 15:50:31 +0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-10-05 13:25:58 +0000
commit35e7b9d2774e8d104d0693e0a0758363c2afb16d (patch)
tree926eb79fc153cf68ed6b7a54cf68f6894ef50f07 /meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-inference-agl_0.2.0.bb
parent39319e3a3bdfcc6c6da47035bf04b4255aec09e5 (diff)
Add dependencies for intent engine snips
This adds the libraries for the snips intent engine. Bug-AGL: SPEC-4856 Change-Id: I0acec6fdd1d0809ee2a0a52ee2c95cd86671d760 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-inference-agl_0.2.0.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-inference-agl_0.2.0.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-inference-agl_0.2.0.bb b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-inference-agl_0.2.0.bb
new file mode 100644
index 00000000..df18ac53
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-inference-agl_0.2.0.bb
@@ -0,0 +1,52 @@
+SUMMARY = "Inference only module of Snips NLU library"
+HOMEPAGE = "https://github.com/malik727/snips-inference-agl"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ecab3ce0771d366e0f8e4ca058eb48e7"
+
+SRC_URI += " \
+ git://github.com/malik727/snips-inference-agl.git;protocol=https;branch=main \
+ "
+
+PV = "0.2.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+SRCREV = "6d45b8d814b1937251524dd8a1e8cac0d8cab5de"
+
+DEPENDS += " \
+ python3-setuptools-native \
+ python3-numpy-native \
+ python3-numpy \
+ python3-num2words \
+ python3-pyaml \
+ python3-six \
+ python3-requests \
+ python3-deprecation \
+ python3-future \
+ python3-scipy \
+ python3-scikit-learn \
+ python3-threadpoolctl \
+ python3-sklearn-crfsuite \
+ python3-tqdm \
+ python3-packaging \
+ python3-snips-nlu-utils \
+ python3-snips-nlu-parsers \
+ "
+
+inherit setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-numpy \
+ python3-num2words \
+ python3-pyaml \
+ python3-six \
+ python3-requests \
+ python3-deprecation \
+ python3-future \
+ python3-scipy \
+ python3-scikit-learn \
+ python3-threadpoolctl \
+ python3-sklearn-crfsuite \
+ python3-tqdm \
+ python3-packaging \
+ python3-snips-nlu-utils \
+ python3-snips-nlu-parsers \
+ "