summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-vosk/python3-vosk-api_0.3.42.bb
diff options
context:
space:
mode:
authoramanarora_09 <aman.arora9848@gmail.com>2022-07-22 15:58:23 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-07-28 13:58:18 +0000
commiteda84d25d819824d641cf89af1e4d61a5e946744 (patch)
tree38f4b7c34a5b91257518bcbcdc6b96d24f0641b2 /meta-offline-voice-agent/recipes-python/python3-vosk/python3-vosk-api_0.3.42.bb
parentf206eab5753bd9ee2d5b1126c6ec5a18e75cac89 (diff)
meta-offline-voice-agent: Enable layer for offline voice recognition
- This enables offline voice recognition in AGL - Can successfully run vosk API and vosk websocket server Changes: - Create a new layer: meta-offline-voice-recognition - Create recipes for the the Vosk library, API, websocket server and model - Create feature template for the layer (agl-offline-voice-agent) - Add all required packages to IMAGE_INSTALL - ptest enable recipe python3-vosk-api - Few fixes Bug-AGL: SPEC-4497 Change-Id: Icb290ceee22e2c3a51cbd67f7431701795f1201b Signed-off-by: amanarora_09 <aman.arora9848@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-vosk/python3-vosk-api_0.3.42.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-vosk/python3-vosk-api_0.3.42.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-vosk/python3-vosk-api_0.3.42.bb b/meta-offline-voice-agent/recipes-python/python3-vosk/python3-vosk-api_0.3.42.bb
new file mode 100644
index 00000000..ba15bd56
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-vosk/python3-vosk-api_0.3.42.bb
@@ -0,0 +1,48 @@
+SUMMARY = "Offline open source speech recognition API based on Kaldi and Vosk"
+HOMEPAGE = "https://github.com/alphacep/vosk-api"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://../COPYING;md5=d09bbd7a3746b6052fbd78b26a87396b"
+
+SRC_URI = "git://github.com/alphacep/vosk-api;protocol=https;branch=master \
+ file://0001-Change-library-search-path-to-usr-lib.patch \
+ file://run-ptest \
+ "
+
+PV = "0.3.42+git${SRCPV}"
+SRCREV = "b1b216d4c87d708935f1601287fe502aa11ee4a9"
+
+S = "${WORKDIR}/git/python"
+
+inherit setuptools3 ptest
+
+DEPENDS += " \
+ python3-srt-native \
+ python3-tqdm-native \
+ python3-requests-native \
+ python3-pip-native \
+ python3-charset-normalizer-native \
+"
+
+RDEPENDS:${PN} += " \
+ python3-cffi \
+ python3-compression \
+ python3-core \
+ python3-datetime \
+ python3-json \
+ python3-logging \
+ python3-misc \
+ python3-multiprocessing \
+ python3-netclient \
+ python3-requests \
+ python3-tqdm \
+ python3-srt \
+ python3-charset-normalizer \
+ python3-sounddevice \
+ virtual/vosk-model \
+"
+
+do_install_ptest () {
+ install -d ${D}${PTEST_PATH}/tests/
+ cp ${S}/example/test_simple.py ${D}${PTEST_PATH}/tests/
+ cp ${S}/example/test.wav ${D}${PTEST_PATH}/tests/
+}