summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-10-06 01:46:44 +0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-10-06 13:19:50 +0000
commit713efdf66dca8e60c3db1e720a9bb2bd074c40f3 (patch)
tree2a0442fee5812d4d5c19016ab479ab3daa30406b /meta-offline-voice-agent/recipes-python
parent88775acac57bdd2184180ad672a410b1155f1e1f (diff)
Fix Scipy, OpenBlas, and NumPy library linking issues
This fixes the linking issues primarily between Scipy and OpenBlas caused due to Scipy expecting a different name for OpenBlas dynamic linking library. Bug-AGL: SPEC-4925 Change-Id: Idb8f620134d63e7d9425a0df8942370430b3f700 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy-native_1.8.1.bb1
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb2
2 files changed, 3 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy-native_1.8.1.bb b/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy-native_1.8.1.bb
index ca46f9db..8827e58e 100644
--- a/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy-native_1.8.1.bb
+++ b/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy-native_1.8.1.bb
@@ -20,6 +20,7 @@ DEPENDS += " \
${PYTHON_PN}-beniget-native \
${PYTHON_PN}-ply-native \
lapack-native \
+ openblas-native \
"
CLEANBROKEN = "1"
diff --git a/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb b/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb
index 2c9424e6..1f562ebf 100644
--- a/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb
+++ b/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb
@@ -19,6 +19,7 @@ DEPENDS += " \
${PYTHON_PN}-beniget-native \
${PYTHON_PN}-ply-native \
lapack \
+ openblas \
"
inherit pypi setuptools3
@@ -26,6 +27,7 @@ inherit pypi setuptools3
RDEPENDS:${PN} += " \
${PYTHON_PN}-numpy \
lapack \
+ openblas \
"
CLEANBROKEN = "1"