summaryrefslogtreecommitdiffstats
path: root/meta-pipewire/recipes-multimedia/wireplumber/wireplumber_git.bb
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2019-12-05 17:08:12 +0200
committerGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2019-12-05 18:42:36 +0200
commite4c7027b142672964fdbf788a7495a39a1f46d5f (patch)
treeb5389d5c9b39d54304cc84f975365809cecd7917 /meta-pipewire/recipes-multimedia/wireplumber/wireplumber_git.bb
parentab9070a7b8cf2dcbfbf56ec4f24f77ea6e5f927c (diff)
wireplumber: update to master as of Dec 5th 2019
This update introduces a new TOML configuration file based policy engine, which behaves the same as the previous static engine, except that we now can: * link different apps to different devices * finetune how the device is configured with a lot of properties that we can match against * force a specific role to a specific app, by overriding it in the configuration file * make a specific app remain linked to the output even if another app comes in to play something; this is useful for the bluez-alsa gstreamer helper at this moment In addition, the code is cleaner and easier to work with, and we can easily add more properties to force a specific behavior per app. Bug-AGL: SPEC-2837 Change-Id: If0ecd468592b78cb2f2a5a8c3db16f655e4927f9 Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com>
Diffstat (limited to 'meta-pipewire/recipes-multimedia/wireplumber/wireplumber_git.bb')
-rw-r--r--meta-pipewire/recipes-multimedia/wireplumber/wireplumber_git.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-pipewire/recipes-multimedia/wireplumber/wireplumber_git.bb b/meta-pipewire/recipes-multimedia/wireplumber/wireplumber_git.bb
index 0ea29752..d89ca5cb 100644
--- a/meta-pipewire/recipes-multimedia/wireplumber/wireplumber_git.bb
+++ b/meta-pipewire/recipes-multimedia/wireplumber/wireplumber_git.bb
@@ -11,12 +11,22 @@ inherit meson pkgconfig gobject-introspection
DEPENDS = "glib-2.0 glib-2.0-native pipewire"
-SRC_URI = "git://gitlab.freedesktop.org/pipewire/wireplumber.git;protocol=https;branch=master"
-SRCREV = "59ab08ff0c9ff8b80dba93b8928db99f1a222ac4"
+SRC_URI = "\
+ git://gitlab.freedesktop.org/pipewire/wireplumber.git;protocol=https;branch=master \
+ https://raw.githubusercontent.com/skystrife/cpptoml/fededad7169e538ca47e11a9ee9251bc361a9a65/include/cpptoml.h \
+ file://0001-Build-cpptoml-without-a-cmake-subproject.patch \
+"
+SRCREV = "8bdadd5a71510afce3254976605a2860fedc2a0b"
+SRC_URI[sha256sum] = "3e4e1d315fa1229921c7a4297ead08775b5bb1220c18a7eac62db9ca7e79df0d"
PV = "0.1.90+git${SRCPV}"
S = "${WORKDIR}/git"
+do_configure_prepend() {
+ mkdir -p ${WORKDIR}/git/subprojects/cpptoml/include
+ cp -f ${WORKDIR}/cpptoml.h ${WORKDIR}/git/subprojects/cpptoml/include/
+}
+
PACKAGES =+ "${PN}-config"
FILES_${PN} += "\