summaryrefslogtreecommitdiffstats
path: root/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-09-08 13:23:42 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-02-05 14:56:52 +0000
commit8bf3c50ab7eb48f8db63ea41d6a12e32f3633dee (patch)
treeacf5541f19ca2a40ef1361e0757485d91e0b05c6 /meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in
parentd369fae7ef2e0bcbd934c838145b08a443b414ff (diff)
Changes: - Mask out the duplicate libopus recipe, the same version is available from a recipe in meta-oe. - Update BBFILES addition for the audio module in the feature template to work with yet another new audio output backend. - Update the AlexaAutoCoreEngineConfig.json.in template based on the new sample JSON in 2.3. - Update alexa-voiceagent-config recipe to add new configuration variables ALEXA_LOCALE, ALEXA_TIMEZONE, ALEXA_MFG_NAME, and ALEXA_DESCRIPTION to match requirements of the updated configuration JSON. - Remove local alexa-voiceagent-service patches merged by Amazon, and update 0001-remove-library-dependency-copying.patch for 2.3. - Update SDK module DEPENDS for alexa-voiceagent-service recipe to match what seems required now with 2.3. - Remove avs-device-sdk patch for building with g++ 9.x, as it is no longer required. - Add avs-device-sdk patch to workaround hang seen on first connection. - Add bbappends for aac-module-car-control and aac-module-messaging recipes to fix their nlohmann-json DEPENDS to work with the recipe that is available in meta-oe. - Rework aac-module-system-audio.bbappend to enable the PipeWire support that has been merged into the module. Bug-AGL: SPEC-3783 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I18c910f9cbf874fef85d1d84508f6666d53629ed (cherry picked from commit e0d5ad833e89f47c88601e15158015319e568af8)
Diffstat (limited to 'meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in')
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in170
1 files changed, 25 insertions, 145 deletions
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in
index 9ead4893..4bf00f89 100644
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in
+++ b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config/AlexaAutoCoreEngineConfig.json.in
@@ -1,55 +1,34 @@
{
"deviceInfo":
{
- "clientId":"@@ALEXA_CLIENTID@@",
- "deviceSerialNumber":"@@ALEXA_SERIALNUMBER@@",
- "productId":"@@ALEXA_PRODUCTID@@"
+ "clientId": "@@ALEXA_CLIENTID@@",
+ "deviceSerialNumber": "@@ALEXA_SERIALNUMBER@@",
+ "productId": "@@ALEXA_PRODUCTID@@",
+ "manufacturerName": "@@ALEXA_MFG_NAME@@",
+ "description": "@@ALEXA_DESCRIPTION@@"
},
"libcurlUtils":
{
"CURLOPT_CAPATH":"/etc/ssl/certs"
},
- "miscDatabase":
- {
- "databaseFilePath":"./miscDatabase.db"
- },
- "certifiedSender":
- {
- "databaseFilePath":"./certifiedSender.db"
- },
- "alertsCapabilityAgent":
- {
- "databaseFilePath":"./alertsCapabilityAgent.db"
- },
- "notifications":
- {
- "databaseFilePath":"./notifications.db"
- },
- "settings":
- {
- "databaseFilePath":"./settings.db",
- "defaultAVSClientSettings":
- {
- "locale":"en-US"
- }
- },
- "aace.storage": {
- "localStoragePath": "./sample-aace.db",
- "storageType": "sqlite"
+ "deviceSettings": {
+ "defaultLocale":"@@ALEXA_LOCALE@@",
+ "defaultTimezone":"@@ALEXA_TIMEZONE@@"
},
"aace.vehicle": {
"info": {
"make": "Amazon",
- "model": "AACE",
- "year": "2018",
+ "model": "AutoSDK",
+ "year": "2019",
"trim": "aac",
"geography": "US",
"version": "1.2.3",
- "os": "sample-aace",
- "arch": "sample-aace",
+ "os": "AGL",
+ "arch": "aarch64",
"language": "en_US",
"microphone": "SingleArray",
- "countries": "US,GB,IE,CA,DE,AT,IN,JP,AU,NZ,FR"
+ "countries": "US,GB,IE,CA,DE,AT,IN,JP,AU,NZ,FR",
+ "vehicleIdentifier": "Sample Identifier ABC"
},
"operatingCountry": "US",
"currentLocation": "36.1363,-115.1513"
@@ -58,11 +37,12 @@
"voice": "Default"
},
"aace.audio.output": {
- "tts": "Speech-High",
- "music": "Speech-Low"
+ "tts": "Speech-Low",
+ "music": "Speech-High",
+ "alarm": "Custom-Low"
},
"aace.wakeword": {
- "enabled":@@WAKEWORD@@
+ "enabled":@@ALEXA_WAKEWORD@@
},
"aace.cbl": {
"enabled": true
@@ -70,115 +50,15 @@
"aace.localmediasource": {
"enabled":false,
"sources": {
- "bluetooth":false,
- "usb":false,
- "fmRadio":false,
- "amRadio":false,
+ "bluetooth":true,
+ "usb":true,
+ "fmRadio":true,
+ "amRadio":true,
"satelliteRadio":false,
"lineIn":false,
- "compactDisc":false
- }
- },
- "aace.localvoicecontrol": {
- "enabled":false,
- "socketRootDirectory":"/var/"
- },
- "aace.localskills": {
- "aace.carcontrol": {
- "enabled": false,
- "cannedzones": [
- {
- "name" : "zone.all",
- "enabled": true,
- "climate": {
- "syncController": false,
- "recirculationController": false
- },
- "airconditioner" : {
- "modes": {
- "AUTO": true,
- "ECONOMY": false,
- "MANUAL": false,
- "MAXIMIUM": false
- }
- },
- "heater" : {
- "minimum": 60.0,
- "maximum": 80.0,
- "precision": 1.0,
- "unit": "FAHRENHEIT"
- },
- "fan" : {
- "minimum": 0.0,
- "maximium": 10.0,
- "precision": 1.0
- },
- "vent": {
- "positions" : {
- "BODY": true,
- "MIX": false,
- "FLOOR": false,
- "WINDSHIELD": false
- }
- },
- "window" : {
- "defrost": true
- },
- "light" : {
- "type": "LIGHT",
- "colors" : {
- "WHITE": true,
- "RED": true,
- "ORANGE": true,
- "YELLOW": true,
- "GREEN": true,
- "BLUE": true,
- "INDIGO": true,
- "VIOLET": true
- }
- }
- },
- {
- "name" : "zone.back.driver",
- "enabled": false
- },
- {
- "name" : "zone.back.passenger",
- "enabled": false
- },
- {
- "name" : "zone.driver",
- "enabled": false
- },
- {
- "name" : "zone.first.row",
- "enabled": false
- },
- {
- "name" : "zone.fourth.row",
- "enabled": false
- },
- {
- "name" : "zone.front",
- "enabled": false
- },
- {
- "name" : "zone.passenger",
- "enabled": false
- },
- {
- "name" : "zone.rear",
- "enabled": false
- },
- {
- "name" : "zone.second.row",
- "enabled": false
- },
- {
- "name" : "zone.third.row",
- "enabled": false
- }
- ]
+ "compactDisc":true,
+ "siriusXM":false,
+ "dab":false
}
}
}