summaryrefslogtreecommitdiffstats
path: root/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend')
-rw-r--r--meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend b/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
index 56650669..53adec9c 100644
--- a/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
+++ b/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
@@ -25,19 +25,19 @@ SRC_URI += " \
SRC_URI += " \
file://0016-Imprement-drm-lease-support.patch \
file://0017-drm-lease-Fix-incorrect-drawing-with-portrait-orient.patch \
+ file://psplash-drmlease.conf \
"
# Licesnse checksum was changed by above patches
LIC_FILES_CHKSUM = "file://psplash.h;beginline=1;endline=8;md5=db1ed16abf4be6de3d79201093ac4f07"
-PACKAGECONFIG[drm] = "--enable-drm,,libdrm"
-PSPLASH_ARGS += "${@bb.utils.contains('PACKAGECONFIG', 'drm', '--drm', '', d)}"
+PACKAGECONFIG:append = " drm drm-lease"
+PACKAGECONFIG[drm] = "--enable-drm,,libdrm"
PACKAGECONFIG[drm-lease] = "--enable-drm-lease,,drm-lease-manager"
-PSPLASH_DRM_LEASE_ARGS ??= "--drm-lease lease0"
-PSPLASH_ARGS += "${@bb.utils.contains('PACKAGECONFIG', 'drm-lease', '${PSPLASH_DRM_LEASE_ARGS}', '', d)}"
-RDEPENDS:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'drm-lease', 'drm-lease-manager', '', d)}"
do_install:append () {
- sed -i -e "s!^\(ExecStart=/usr/bin/psplash.*\)!\1 ${PSPLASH_ARGS}!" ${D}${systemd_system_unitdir}/psplash-start.service
+ # Install override
+ install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
+ install -m 0644 ${WORKDIR}/psplash-drmlease.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}