summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-flutter')
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb3
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-debug_%.bbappend1
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-profile_%.bbappend1
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-release_%.bbappend1
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-gallery_aglflutter.inc1
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc2
6 files changed, 4 insertions, 5 deletions
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb
index 09250d6b..c5c8b2ae 100644
--- a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb
+++ b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb
@@ -15,5 +15,8 @@ SRCREV = "08bf271f7f1f14153a41005718a2090fa8e783f0"
S = "${WORKDIR}/git"
PUBSPEC_APPNAME = "flutter_homescreen"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+
+FLUTTER_BUILD_ARGS = "bundle -v"
inherit flutter-app
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-debug_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-debug_%.bbappend
deleted file mode 100644
index 835e86e6..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-debug_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', 'flutter-gallery_aglflutter.inc', '', d)}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-profile_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-profile_%.bbappend
deleted file mode 100644
index 835e86e6..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-profile_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', 'flutter-gallery_aglflutter.inc', '', d)}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-release_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-release_%.bbappend
deleted file mode 100644
index 835e86e6..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery-release_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', 'flutter-gallery_aglflutter.inc', '', d)}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery_aglflutter.inc b/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery_aglflutter.inc
deleted file mode 100644
index ef03af27..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/flutter-gallery_aglflutter.inc
+++ /dev/null
@@ -1 +0,0 @@
-do_compile[network] = "1"
diff --git a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc
index dd3b8ec0..4c013419 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc
+++ b/meta-agl-flutter/recipes-graphics/toyota/ivi-homescreen_aglflutter.inc
@@ -7,7 +7,7 @@
PACKAGECONFIG:remove = "gstreamer"
# AGL specifics
-IVI_HOMESCREEN_APP_OVERRIDE = "--a=/usr/share/gallery"
+IVI_HOMESCREEN_APP_OVERRIDE = "--a=/usr/share/flutter/gallery"
SERVICE_UNIT = "Requires=agl-compositor.service\nAfter=agl-compositor.service"
SERVICE_INSTALL = "WantedBy=agl-session.target"