summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend')
-rw-r--r--meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend b/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend
new file mode 100644
index 00000000..75ab98c0
--- /dev/null
+++ b/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend
@@ -0,0 +1,25 @@
+PACKAGECONFIG:remove = "templates"
+
+SYSTEMD_AUTO_ENABLE:${PN} = "enable"
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+SRC_URI += " \
+ file://lxc.service \
+ file://lxc-net.service \
+ "
+
+do_install:append () {
+ for service in lxc.service lxc-net.service; do
+ install -D -m 0644 ${WORKDIR}/$service ${D}${systemd_system_unitdir}/$service
+ sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' ${D}${systemd_system_unitdir}/$service
+ done
+}
+
+# NOTE:
+# This needs to be replaced with a rework of the upstream packaging
+# to do a proper split of core from the template support.
+RDEPENDS:${PN} = ""
+
+
+