summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-demo/momiweb/momiweb_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-ic-container/recipes-demo/momiweb/momiweb_git.bb')
-rw-r--r--meta-agl-ic-container/recipes-demo/momiweb/momiweb_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-demo/momiweb/momiweb_git.bb b/meta-agl-ic-container/recipes-demo/momiweb/momiweb_git.bb
new file mode 100644
index 00000000..afdbfc33
--- /dev/null
+++ b/meta-agl-ic-container/recipes-demo/momiweb/momiweb_git.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Momiyama Web UI for CES2023"
+DESCRIPTION = "Momiyama Web UI for CES2023."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
+
+PV = "0.1.0"
+
+SRC_URI = "git://github.com/agl-ic-eg/momiweb.git;protocol=https;branch=main \
+ file://momiweb.conf \
+ "
+SRCREV = "cfdfdd670a83558a408bafa7b0262381313b907d"
+
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/lighttpd.d
+ install -m 0644 ${WORKDIR}/momiweb.conf ${D}${sysconfdir}/lighttpd.d/
+
+ install -d ${D}/www/momiweb
+ cp -R ${S}/webui/* ${D}/www/momiweb/
+
+ install -d ${D}/www/cgi-bin
+ cp -R ${S}/cgi/* ${D}/www/cgi-bin/
+}
+
+FILES:${PN} += " \
+ /www/momiweb/* \
+ /www/momiweb/*/* \
+ /www/cgi-bin/* \
+ "
+RDEPENDS:${PN} = " \
+ lighttpd \
+ lighttpd-module-cgi \
+ lighttpd-module-alias \
+ lighttpd-module-access \
+ lighttpd-module-accesslog \
+ "