summaryrefslogtreecommitdiffstats
path: root/meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend')
-rw-r--r--meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend b/meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend
index 72078495..b8456f7f 100644
--- a/meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend
+++ b/meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend
@@ -2,6 +2,15 @@ PACKAGECONFIG:remove = "templates"
SYSTEMD_AUTO_ENABLE:${PN} = "enable"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://lxc.service"
+
+do_install:append () {
+ install -D -m 0644 ${WORKDIR}/lxc.service ${D}${systemd_system_unitdir}/lxc.service
+ sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' ${D}${systemd_system_unitdir}/lxc.service
+}
+
# NOTE:
# This needs to be replaced with a rework of the upstream packaging
# to do a proper split of core from the template support.