summaryrefslogtreecommitdiffstats
path: root/meta-agl-test/recipes-tests/glib2/agl-test-glib2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-test/recipes-tests/glib2/agl-test-glib2.bb')
-rw-r--r--meta-agl-test/recipes-tests/glib2/agl-test-glib2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-agl-test/recipes-tests/glib2/agl-test-glib2.bb b/meta-agl-test/recipes-tests/glib2/agl-test-glib2.bb
new file mode 100644
index 00000000..fe0da800
--- /dev/null
+++ b/meta-agl-test/recipes-tests/glib2/agl-test-glib2.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Glib2 Test"
+HOMEPAGE = "https://git.automotivelinux.org/src/qa-test-misc/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+PN = 'agl-test-glib2'
+PV = '1'
+
+FILESEXTRAPATHS:append := "${TMPDIR}/work/aarch64-agl-linux/qa-test-misc/1-r0/git/:"
+SRC_URI = "file://glib2/ \
+ file://LICENSE "
+
+do_fetch[depends] = "qa-test-misc:do_unpack"
+
+S = "${WORKDIR}"
+
+FILES:${PN} += " \
+ /usr/AGL/agl-test/tests/glib2 \
+"
+
+do_install:append() {
+ install -d ${D}/usr/AGL/agl-test/tests/glib2/
+ install -m 0644 ${WORKDIR}/glib2/rootfs-scripts/*.py ${D}/usr/AGL/agl-test/tests/glib2/
+}
+
+RDEPENDS:${PN} += " \
+ agl-test-framework \
+ glib-2.0 \
+"