summaryrefslogtreecommitdiffstats
path: root/meta-agl-test/recipes-tests/rpm/agl-test-rpm.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-test/recipes-tests/rpm/agl-test-rpm.bb')
-rw-r--r--meta-agl-test/recipes-tests/rpm/agl-test-rpm.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-agl-test/recipes-tests/rpm/agl-test-rpm.bb b/meta-agl-test/recipes-tests/rpm/agl-test-rpm.bb
new file mode 100644
index 00000000..94e9da95
--- /dev/null
+++ b/meta-agl-test/recipes-tests/rpm/agl-test-rpm.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Rpm Test Set"
+HOMEPAGE = "https://git.automotivelinux.org/src/qa-test-misc/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+PN = 'agl-test-rpm'
+PV = '1'
+
+FILESEXTRAPATHS:append := "${TMPDIR}/work/aarch64-agl-linux/qa-test-misc/1-r0/git/:"
+
+SRC_URI = "file://rpm/ \
+ file://LICENSE "
+
+do_fetch[depends] = "qa-test-misc:do_unpack"
+
+S = "${WORKDIR}"
+
+FILES:${PN} += " \
+ /usr/AGL/agl-test/tests/rpm \
+"
+
+do_install:append() {
+ install -d ${D}/usr/AGL/agl-test/tests/rpm/resource/tests/
+ install -m 0644 ${WORKDIR}/rpm/rootfs-scripts/*.py ${D}/usr/AGL/agl-test/tests/rpm/
+ install -m 0644 ${WORKDIR}/rpm/rootfs-scripts/resource/rpm_test.sh ${D}/usr/AGL/agl-test/tests/rpm/resource/
+ install -m 0644 ${WORKDIR}/rpm/rootfs-scripts/resource/test-manual-1.2.3.noarch.rpm ${D}/usr/AGL/agl-test/tests/rpm/resource/
+ install -m 0644 ${WORKDIR}/rpm/rootfs-scripts/resource/tests/* ${D}/usr/AGL/agl-test/tests/rpm/resource/tests/
+}
+
+RDEPENDS:${PN} += " \
+ agl-test-framework \
+ rpm \
+"