aboutsummaryrefslogtreecommitdiffstats
path: root/meta-elisa/recipes-kernel/linux/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'meta-elisa/recipes-kernel/linux/files/Makefile')
-rw-r--r--meta-elisa/recipes-kernel/linux/files/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-elisa/recipes-kernel/linux/files/Makefile b/meta-elisa/recipes-kernel/linux/files/Makefile
new file mode 100644
index 00000000..017577c7
--- /dev/null
+++ b/meta-elisa/recipes-kernel/linux/files/Makefile
@@ -0,0 +1,12 @@
+obj-m += edac_inject.o
+
+export KDIR := /lib/modules/$(shell uname -r)/build
+
+allofit: modules
+modules:
+ @$(MAKE) -C $(KDIR) M=$(shell pwd) modules
+kernel_clean:
+ @$(MAKE) -C $(KDIR) M=$(shell pwd) clean
+
+clean: kernel_clean
+ rm -rf Module.symvers modules.order