summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb')
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
new file mode 100644
index 00000000..edcb9fe4
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Voice Assistant"
+DESCRIPTION = "Offline voice assistant app designed for Automotive Grade Linux (AGL)."
+HOMEPAGE = "https://github.com/malik727/agl-flutter-voiceassistant"
+BUGTRACKER = "https://github.com/malik727/agl-flutter-voiceassistant/issues"
+SECTION = "graphics"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4202492ed9afcab3aaecc4a9ec32adb2"
+
+SRC_URI = "\
+ git://gerrit.automotivelinux.org/gerrit/apps/flutter-speechrecognition-demo;protocol=https;branch=${AGL_BRANCH} \
+ "
+
+SRCREV = "${AUTOREV}"
+S = "${WORKDIR}/git"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "flutter_voiceassistant"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "flutter_voiceassistant"
+AGL_APP_NAME = "Voice Assistant" \ No newline at end of file