summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-assistant
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-assistant')
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service9
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb15
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb5
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-service/files/agl-service-voiceagent.service3
4 files changed, 24 insertions, 8 deletions
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service
new file mode 100644
index 00000000..101326b3
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=flutter_voiceassistant
+
+[Service]
+Type=simple
+User=agl-driver
+EnvironmentFile=/etc/default/flutter
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
+ExecStart=/usr/bin/flutter-auto --b=/flutter/flutter_voiceassistant/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --xdg-shell-app-id=flutter_voiceassistant
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
index edcb9fe4..67263790 100644
--- a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
@@ -8,12 +8,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4202492ed9afcab3aaecc4a9ec32adb2"
SRC_URI = "\
git://gerrit.automotivelinux.org/gerrit/apps/flutter-speechrecognition-demo;protocol=https;branch=${AGL_BRANCH} \
- "
-
+ file://agl-app-flutter@flutter_voiceassistant.service \
+"
+
SRCREV = "${AUTOREV}"
S = "${WORKDIR}/git"
-inherit agl-app flutter-app
+inherit agl-app flutter-app
# flutter-app
#############
@@ -25,4 +26,10 @@ FLUTTER_BUILD_ARGS = "bundle -v"
#########
AGL_APP_TEMPLATE = "agl-app-flutter"
AGL_APP_ID = "flutter_voiceassistant"
-AGL_APP_NAME = "Voice Assistant" \ No newline at end of file
+AGL_APP_NAME = "Voice Assistant"
+
+do_install:append() {
+ install -D -m 0644 ${WORKDIR}/agl-app-flutter@flutter_voiceassistant.service ${D}${systemd_system_unitdir}/agl-app-flutter@flutter_voiceassistant.service
+}
+
+FILES:${PN} += "${datadir} "
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb b/meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb
index 7b6139d2..e1f1cc50 100644
--- a/meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb
@@ -30,6 +30,7 @@ SYSTEMD_SERVICE:${PN} = "agl-service-voiceagent.service"
do_compile:prepend() {
# Generate proto files and move them to 'generated/' directory
python3 -m grpc_tools.protoc -I${S}/agl_service_voiceagent/protos --python_out=${S}/agl_service_voiceagent/generated --grpc_python_out=${S}/agl_service_voiceagent/generated voice_agent.proto
+ python3 -m grpc_tools.protoc -I${S}/agl_service_voiceagent/protos --python_out=${S}/agl_service_voiceagent/generated --grpc_python_out=${S}/agl_service_voiceagent/generated audio_processing.proto
# Replace all placeholders with actual values
sed -i 's|PYTHON_DIR|${PYTHON_SITEPACKAGES_DIR}|g' ${S}/agl_service_voiceagent/config.ini
@@ -62,9 +63,9 @@ RDEPENDS:${PN} += " \
python3-grpcio-tools \
python3-pygobject \
kuksa-client \
- python3-rasa \
python3-snips-inference-agl \
vosk \
+ whisper \
"
-FILES:${PN} += "/usr/share/nlu/" \ No newline at end of file
+FILES:${PN} += "/usr/share/nlu/"
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-service/files/agl-service-voiceagent.service b/meta-offline-voice-agent/recipes-assistant/voiceagent-service/files/agl-service-voiceagent.service
index 54139431..b4d738f8 100644
--- a/meta-offline-voice-agent/recipes-assistant/voiceagent-service/files/agl-service-voiceagent.service
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-service/files/agl-service-voiceagent.service
@@ -1,11 +1,10 @@
[Unit]
Description=AGL Voice Agent Service
After=network.target
-Requires=rasa-service.service
[Service]
ExecStart=/usr/bin/voiceagent-service run-server --default
Restart=always
[Install]
-WantedBy=multi-user.target \ No newline at end of file
+WantedBy=multi-user.target