summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/llvmlite
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/llvmlite')
-rw-r--r--meta-offline-voice-agent/recipes-python/llvmlite/files/LICENSE24
-rw-r--r--meta-offline-voice-agent/recipes-python/llvmlite/llvmlite_0.43.0.bb34
2 files changed, 58 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/llvmlite/files/LICENSE b/meta-offline-voice-agent/recipes-python/llvmlite/files/LICENSE
new file mode 100644
index 00000000..8e94a016
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/llvmlite/files/LICENSE
@@ -0,0 +1,24 @@
+Copyright (c) 2014-, Continuum Analytics, Inc.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+Redistributions of source code must retain the above copyright notice,
+this list of conditions and the following disclaimer.
+
+Redistributions in binary form must reproduce the above copyright
+notice, this list of conditions and the following disclaimer in the
+documentation and/or other materials provided with the distribution.
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/meta-offline-voice-agent/recipes-python/llvmlite/llvmlite_0.43.0.bb b/meta-offline-voice-agent/recipes-python/llvmlite/llvmlite_0.43.0.bb
new file mode 100644
index 00000000..e34abd59
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/llvmlite/llvmlite_0.43.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "llvmlite prebuilt binary"
+HOMEPAGE = "https://github.com/numba/llvmlite"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=a15ea9843f27327e08f3c5fbf8043a2b"
+
+SRCURIWHEEL:aarch64 += "https://files.pythonhosted.org/packages/bf/f1/4c205a48488e574ee9f6505d50e84370a978c90f08dab41a42d8f2c576b6/llvmlite-0.43.0-cp312-cp312-manylinux_2_17_aarch64.manylinux2014_aarch64.whl"
+SRCURIWHEEL:x86-64 += "https://files.pythonhosted.org/packages/00/5f/323c4d56e8401c50185fd0e875fcf06b71bf825a863699be1eb10aa2a9cb/llvmlite-0.43.0-cp312-cp312-manylinux_2_17_x86_64.manylinux2014_x86_64.whl"
+SRC_URI = " ${SRCURIWHEEL} "
+SRC_URI:append = " file://LICENSE "
+
+SRCURICHECKSUM:x86-64 = "df6509e1507ca0760787a199d19439cc887bfd82226f5af746d6977bd9f66844"
+SRCURICHECKSUM:aarch64 = "eccce86bba940bae0d8d48ed925f21dbb813519169246e2ab292b5092aba121f"
+SRC_URI[sha256sum] = "${SRCURICHECKSUM}"
+
+COMPATIBLE_MACHINE = "null"
+COMPATIBLE_MACHINE:aarch64 = "(.*)"
+COMPATIBLE_MACHINE:x86-64 = "(.*)"
+
+DEPENDS += " unzip-native"
+
+RDEPENDS:${PN} += " zlib"
+
+do_install() {
+ mkdir -p ${WORKDIR}/llvmlite-0.43.0
+ unzip ${WORKDIR}/$(basename ${SRC_URI}) -d ${WORKDIR}/llvmlite-0.43.0
+ install -d ${D}/usr/lib/python3.12/site-packages
+ cp -R ${WORKDIR}/llvmlite-0.43.0/* ${D}/usr/lib/python3.12/site-packages/
+}
+
+do_configure:prepend() {
+ export LD_LIBRARY_PATH="${D}/usr/lib/python3.12/site-packages/llvmlite/binding:${LD_LIBRARY_PATH}"
+}
+
+FILES:${PN} += "/usr/lib/python3.12/site-packages/* "