summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-sdk-remove-group-from-poetry-as-its-not-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-sdk-remove-group-from-poetry-as-its-not-support.patch')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-sdk-remove-group-from-poetry-as-its-not-support.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-sdk-remove-group-from-poetry-as-its-not-support.patch b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-sdk-remove-group-from-poetry-as-its-not-support.patch
new file mode 100644
index 00000000..7c92d9be
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-rasa-sdk-remove-group-from-poetry-as-its-not-support.patch
@@ -0,0 +1,31 @@
+From 39db336c60f5499568802b878acb864008739d48 Mon Sep 17 00:00:00 2001
+From: Malik Talha <talhamalik727x@gmail.com>
+Date: Mon, 7 Aug 2023 02:14:25 +0500
+Subject: [PATCH] rasa-sdk remove group from poetry as its not supported
+
+poetry version < 1.20 does not support group in pyproject.toml
+---
+ pyproject.toml | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index e8882e1..f3e0dec 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -96,6 +96,8 @@ pep440-version-utils = "^0.3.0"
+ semantic_version = "^2.8.5"
+ mypy = "^1.3"
+ sanic-testing = "^22.3.0, <22.9.0"
++ruff = ">=0.0.256,<0.0.276"
++pytest-asyncio = "^0.21.0"
+
+ [tool.ruff.pydocstyle]
+ convention = "google"
+@@ -103,7 +105,3 @@ convention = "google"
+ [tool.pytest.ini_options]
+ python_functions = "test_"
+ asyncio_mode = "auto"
+-
+-[tool.poetry.group.dev.dependencies]
+-ruff = ">=0.0.256,<0.0.276"
+-pytest-asyncio = "^0.21.0"