summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-anyio_3.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-anyio_3.7.1.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-anyio_3.7.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-anyio_3.7.1.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-anyio_3.7.1.bb
new file mode 100644
index 00000000..681eb7f0
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-anyio_3.7.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "AnyIO is an asynchronous networking and concurrency library that works on top of either asyncio or trio"
+HOMEPAGE = "https://github.com/agronholm/anyio"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c0a769411d2af7894099e8ff75058c9f"
+
+PYPI_PACKAGE = "anyio"
+
+SRC_URI += "file://0001-anyio-add-setup-file.patch"
+SRC_URI[md5sum] = "58d288dd84e28e2507ff9ce7e4620010"
+SRC_URI[sha256sum] = "44a3c9aba0f5defa43261a8b3efb97891f2bd7d804e0e1f56419befa1adfc780"
+
+DEPENDS += " \
+ python3-sniffio \
+ python3-idna \
+ python3-exceptiongroup \
+ "
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-sniffio \
+ python3-idna \
+ python3-exceptiongroup \
+ "