summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-cors_2.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-cors_2.0.1.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-cors_2.0.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-cors_2.0.1.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-cors_2.0.1.bb
new file mode 100644
index 00000000..66834a30
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-cors_2.0.1.bb
@@ -0,0 +1,21 @@
+SUMMARY = "A Sanic extension for handling Cross Origin Resource Sharing (CORS), making cross-origin AJAX possible."
+HOMEPAGE = "https://github.com/ashleysommer/sanic-cors"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=db2d9ca6ab6d7568b89656d68b0c01ee"
+
+PYPI_PACKAGE = "Sanic-Cors"
+
+SRC_URI[md5sum] = "9d4e56275332487fb6fdfe8644116e98"
+SRC_URI[sha256sum] = "4d2f26333d49db428217814c66e89fc3df20fc62a5ab518a71fa22e2e249e19d"
+
+DEPENDS += " \
+ python3-packaging \
+ python3-sanic \
+ "
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ python3-packaging \
+ python3-sanic \
+ "