summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-jwt_1.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-jwt_1.8.0.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-jwt_1.8.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-jwt_1.8.0.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-jwt_1.8.0.bb
new file mode 100644
index 00000000..8bc2f47e
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-sanic-jwt_1.8.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Authentication, JWT, and permission scoping for Sanic"
+HOMEPAGE = "https://github.com/ahopkins/sanic-jwt"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c3a2839b22af0a25e097bcfc682c6523"
+
+PYPI_PACKAGE = "sanic-jwt"
+
+SRC_URI[md5sum] = "b043b92964f623041949ac873be113e8"
+SRC_URI[sha256sum] = "ae16cdaebc8cd9569dae6f633a2a876205d7b36134e5920698ae5b8e4f1b83f1"
+
+DEPENDS += "python3-pyjwt"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-pyjwt"