summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-wavio/python3-wavio_0.0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-wavio/python3-wavio_0.0.4.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-wavio/python3-wavio_0.0.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-wavio/python3-wavio_0.0.4.bb b/meta-offline-voice-agent/recipes-python/python3-wavio/python3-wavio_0.0.4.bb
new file mode 100644
index 00000000..6fbb22c7
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-wavio/python3-wavio_0.0.4.bb
@@ -0,0 +1,19 @@
+SUMMARY = "A Python module for reading and writing WAV files using numpy arrays."
+HOMEPAGE = "https://github.com/WarrenWeckesser/wavio"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/README.rst;beginline=48;endline=48;md5=bc752f76db0a3e24c17afcc8dda3d553"
+# License listed in README.rst at https://github.com/WarrenWeckesser/wavio
+
+SRC_URI = "git://github.com/WarrenWeckesser/wavio;protocol=https;branch=master"
+
+PV = "0.0.4+git${SRCPV}"
+SRCREV = "54699acdde2cb4f68fbe3dc5847a74ab796662e1"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-numpy"
+
+RDEPENDS:${PN} += "python3-audio python3-core python3-numpy"