summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-blsched/COPYING.MIT17
-rw-r--r--meta-blsched/README.md42
-rw-r--r--meta-blsched/conf/layer.conf10
-rw-r--r--meta-blsched/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bbappend1
-rw-r--r--meta-blsched/recipes-core/blsched/blsched_git.bb36
-rw-r--r--meta-blsched/recipes-core/blsched/files/blsched.service9
-rw-r--r--meta-blsched/recipes-kernel/linux/linux-renesas_%.bbappend4
-rw-r--r--templates/feature/blsched/50_bblayers.conf.inc3
-rw-r--r--templates/feature/blsched/50_local.conf.inc1
-rw-r--r--templates/feature/blsched/README_feature_blsched.md13
10 files changed, 0 insertions, 136 deletions
diff --git a/meta-blsched/COPYING.MIT b/meta-blsched/COPYING.MIT
deleted file mode 100644
index 89de354..0000000
--- a/meta-blsched/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/meta-blsched/README.md b/meta-blsched/README.md
deleted file mode 100644
index e3a9475..0000000
--- a/meta-blsched/README.md
+++ /dev/null
@@ -1,42 +0,0 @@
-# Baylibre's AGL blsched layer
-
-This README file contains information on the contents of the
-meta-blsched layer.
-
-Please see the corresponding sections below for details.
-
-### Dependencies
--------------------------
-
-The linux kernel must have the following config options enabled:
-CONFIG_CONNECTOR
-CONFIG_PROC_EVENTS
-CONFIG_SCHED_DEBUG
-
-### Patches
------------
-
-Please submit any patches against the meta-blsched layer to the
-the maintainers:
-
-* Michael Turquette <mturquette@baylibre.com>
-* Frode Isaksen <fisaksen@baylibre.com>
-* Jerome Brunet <jbrunet@baylibre.com>
-
-## I. Description and provided packages:
-
-The layer provides blsched utility. This package is a utility to improve scheduling efficiency on big.LITTLE architecture.
-
-+ Provided packages :
- - blsched : see https://github.com/BayLibre/bLsched/blob/master/README.md
- - blsched-daemon : systemd service tailored for r8a7795 and r8a7796 SoCs
-
-## II. Adding the meta-blsched layer to your AGL build
-
-1. Download meta-agl-extra at `$AGL_TOP`
-2. Add `blsched` to the feature of your AGL build<br>
-```shell
-source meta-agl/scripts/aglsetup.sh -m $MACHINE -b <your-other-features> blsched
-```
-
-With this `meta-blsched` will be added to your `conf/bblayers.conf`. `blsched` and `blsched-daemon` will be appended to your image.
diff --git a/meta-blsched/conf/layer.conf b/meta-blsched/conf/layer.conf
deleted file mode 100644
index 68a179a..0000000
--- a/meta-blsched/conf/layer.conf
+++ /dev/null
@@ -1,10 +0,0 @@
-# We have a conf and classes directory, add to BBPATH
-BBPATH .= ":${LAYERDIR}"
-
-# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "blsched"
-BBFILE_PATTERN_blsched = "^${LAYERDIR}/"
-BBFILE_PRIORITY_blsched = "6"
diff --git a/meta-blsched/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bbappend b/meta-blsched/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bbappend
deleted file mode 100644
index b5a7aaa..0000000
--- a/meta-blsched/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-export PSCI_DISABLE_BIGLITTLE_IN_CA57BOOT="${@bb.utils.contains('MACHINE_FEATURES','biglittle','0','1',d)}"
diff --git a/meta-blsched/recipes-core/blsched/blsched_git.bb b/meta-blsched/recipes-core/blsched/blsched_git.bb
deleted file mode 100644
index af7db3a..0000000
--- a/meta-blsched/recipes-core/blsched/blsched_git.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-SUMMARY = "big.LITTLE scheduler"
-HOMEPAGE = "https://github.com/BayLibre/bLsched"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b0df75b2edb80ee98b732ee0514a265c"
-
-SRC_URI = "git://github.com/baylibre/blsched.git \
- file://blsched.service \
- "
-
-SRCREV = "b6bf199bc2def486857fb7003a6cb07708ed685e"
-
-S = "${WORKDIR}/git"
-
-inherit autotools
-
-COMPATIBLE_MACHINE ="((h|m)3ulcb|salvator-x)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-DAEMONARGS_r8a7795 = "-b 0 -b 1 -b 2 -b 3"
-DAEMONARGS_r8a7796 = "-b 0 -b 1"
-
-RDEPENDS_${PN} += " blsched"
-
-inherit systemd
-
-SYSTEMD_SERVICE_${PN} = "blsched.service"
-
-do_install_append () {
- # Install the systemd init file
- install -d ${D}${systemd_unitdir}/system
- install -c -m 0644 ${WORKDIR}/blsched.service ${D}${systemd_unitdir}/system
-
- sed -i -e 's,@SBINDIR@,${sbindir},g' \
- -e 's,@ARGS@,${DAEMONARGS},g' \
- ${D}${systemd_unitdir}/system/*.service
-}
diff --git a/meta-blsched/recipes-core/blsched/files/blsched.service b/meta-blsched/recipes-core/blsched/files/blsched.service
deleted file mode 100644
index b26b1fa..0000000
--- a/meta-blsched/recipes-core/blsched/files/blsched.service
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=blsched big.LITTLE cpu manager service
-After=local-fs.target
-
-[Service]
-ExecStart=@SBINDIR@/blsched @ARGS@
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-blsched/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-blsched/recipes-kernel/linux/linux-renesas_%.bbappend
deleted file mode 100644
index 354734e..0000000
--- a/meta-blsched/recipes-kernel/linux/linux-renesas_%.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-SRC_URI_append = " \
- ${@bb.utils.contains('MACHINE_FEATURES','biglittle','file://procevent.cfg','',d)} \
- ${@bb.utils.contains('MACHINE_FEATURES','biglittle','file://scheddebug.cfg','',d)} \
- "
diff --git a/templates/feature/blsched/50_bblayers.conf.inc b/templates/feature/blsched/50_bblayers.conf.inc
deleted file mode 100644
index 0db260d..0000000
--- a/templates/feature/blsched/50_bblayers.conf.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-BBLAYERS =+ "\
- ${METADIR}/meta-agl-extra/meta-blsched \
- "
diff --git a/templates/feature/blsched/50_local.conf.inc b/templates/feature/blsched/50_local.conf.inc
deleted file mode 100644
index 658230e..0000000
--- a/templates/feature/blsched/50_local.conf.inc
+++ /dev/null
@@ -1 +0,0 @@
-IMAGE_INSTALL_append = " blsched"
diff --git a/templates/feature/blsched/README_feature_blsched.md b/templates/feature/blsched/README_feature_blsched.md
deleted file mode 100644
index a1c9928..0000000
--- a/templates/feature/blsched/README_feature_blsched.md
+++ /dev/null
@@ -1,13 +0,0 @@
----
-description: enable user space big.LITTLE scheduler
-authors: Frode Isaksen <fisaksen@baylibre.com>
----
-
-### Feature blsched
-
-This features enables user space big.LITTLE scheduler.
-
-It optimizes task placement on big.LITTLE platforms.
-
-Currently enabled for Renesas r-car gen3 boards with the machine feature 'biglittle' defined.
-