summaryrefslogtreecommitdiffstats
path: root/meta-attic/recipes-demo-hmi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-attic/recipes-demo-hmi')
-rw-r--r--meta-attic/recipes-demo-hmi/als-meter-demo/als-meter-demo_git.bb21
-rw-r--r--meta-attic/recipes-demo-hmi/controls/controls_git.bb18
-rw-r--r--meta-attic/recipes-demo-hmi/settings-log-utils/settings-log-utils_git.bb24
-rw-r--r--meta-attic/recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch25
-rw-r--r--meta-attic/recipes-demo-hmi/vod-server/files/vod-demo.service10
-rw-r--r--meta-attic/recipes-demo-hmi/vod-server/vod-server_0.1.bb35
-rw-r--r--meta-attic/recipes-demo-hmi/windowmanager/windowmanager_git.bb37
7 files changed, 170 insertions, 0 deletions
diff --git a/meta-attic/recipes-demo-hmi/als-meter-demo/als-meter-demo_git.bb b/meta-attic/recipes-demo-hmi/als-meter-demo/als-meter-demo_git.bb
new file mode 100644
index 0000000..6b0e054
--- /dev/null
+++ b/meta-attic/recipes-demo-hmi/als-meter-demo/als-meter-demo_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Demo app for streeting-wheel"
+DESCRIPTION = "AGL demo app for streeting-wheel"
+HOMEPAGE = "http://192.168.160.148/shenhui/als-meter-demo-release"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/als-meter-demo;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "0.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 opencv libhomescreen qlibwindowmanager"
+
+# runtime dependencies
+RDEPENDS_${PN} += "agl-service-steering-wheel"
+
+inherit qmake5 aglwgt
diff --git a/meta-attic/recipes-demo-hmi/controls/controls_git.bb b/meta-attic/recipes-demo-hmi/controls/controls_git.bb
new file mode 100644
index 0000000..1b19759
--- /dev/null
+++ b/meta-attic/recipes-demo-hmi/controls/controls_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Controls for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating UI components on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/controls"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/controls;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2"
+
+inherit qmake5 aglwgt
diff --git a/meta-attic/recipes-demo-hmi/settings-log-utils/settings-log-utils_git.bb b/meta-attic/recipes-demo-hmi/settings-log-utils/settings-log-utils_git.bb
new file mode 100644
index 0000000..90dc0be
--- /dev/null
+++ b/meta-attic/recipes-demo-hmi/settings-log-utils/settings-log-utils_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "App for log record"
+DESCRIPTION = "AGL HMI Application for demonstrating Log Record on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings-log-utils"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings-log-utils;protocol=https;branch=master"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "libqtappfw qtquickcontrols2 qtwebsockets opencv boost"
+DEPENDS += "libhomescreen qlibwindowmanager qtvirtualkeyboard"
+
+# runtime dependencies
+RDEPENDS_${PN} += " \
+ agl-service-bluetooth \
+ agl-service-network"
+
+inherit qmake5 aglwgt
diff --git a/meta-attic/recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch b/meta-attic/recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch
new file mode 100644
index 0000000..c034d4e
--- /dev/null
+++ b/meta-attic/recipes-demo-hmi/vod-server/files/0001-Fix-cross-compilation-with-yocto.patch
@@ -0,0 +1,25 @@
+--- a/buildX86/Makefile-Release.mk 2016-12-09 15:48:37.000000000 +0100
++++ b/buildX86/Makefile-Release.mk 2016-12-09 16:56:35.071740652 +0100
+@@ -11,14 +11,14 @@
+ MKDIR=mkdir
+ CP=cp
+ GREP=grep
+-NM=nm
+-CCADMIN=CCadmin
+-RANLIB=ranlib
+-CC=${CROSS_COMPILE}gcc
+-CCC=${CROSS_COMPILE}g++
+-CXX=${CROSS_COMPILE}g++
+-FC=${CROSS_COMPILE}gfortran
+-AS=${CROSS_COMPILE}as
++#NM=nm
++#CCADMIN=CCadmin
++#RANLIB=ranlib
++#CC=${CROSS_COMPILE}gcc
++#CCC=${CROSS_COMPILE}g++
++#CXX=${CROSS_COMPILE}g++
++#FC=${CROSS_COMPILE}gfortran
++#AS=${CROSS_COMPILE}as
+
+ # Macros
+ CND_PLATFORM=GNU-Linux-x86
diff --git a/meta-attic/recipes-demo-hmi/vod-server/files/vod-demo.service b/meta-attic/recipes-demo-hmi/vod-server/files/vod-demo.service
new file mode 100644
index 0000000..c783bd4
--- /dev/null
+++ b/meta-attic/recipes-demo-hmi/vod-server/files/vod-demo.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Video On Demand AGL Demo
+After=WindowManager.service most-network-manager.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/VideoOnDemand -p /home/root/Video
+
+[Install]
+WantedBy=default.target
diff --git a/meta-attic/recipes-demo-hmi/vod-server/vod-server_0.1.bb b/meta-attic/recipes-demo-hmi/vod-server/vod-server_0.1.bb
new file mode 100644
index 0000000..d1cbb66
--- /dev/null
+++ b/meta-attic/recipes-demo-hmi/vod-server/vod-server_0.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Build VideoOnDemand server"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+# "
+
+PV = "0.1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch \
+ file://vod-demo.service"
+
+S = "${WORKDIR}/git"
+SRCREV = "faafe61dd5f88859a005a59082d57339089ddca1"
+
+do_install() {
+ install -m 0755 -d ${D}${bindir}
+ install -m 0755 ${S}/VideoOnDemand ${D}${bindir}/VideoOnDemand
+
+ # Install VOD server systemd service (user)
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -m 644 -p -D ${WORKDIR}/vod-demo.service ${D}${systemd_user_unitdir}/vod-demo.service
+
+ # Execute install manually for root user on behalf of systemctl script
+ # because it doesn't support user mode of systemd.
+ install -m 0755 -d ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/
+ ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service
+ sed -i "s:/home/root:${ROOT_HOME}:" ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service
+ fi
+}
+
+FILES_${PN} += " \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/vod-demo.service', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
+ "
diff --git a/meta-attic/recipes-demo-hmi/windowmanager/windowmanager_git.bb b/meta-attic/recipes-demo-hmi/windowmanager/windowmanager_git.bb
new file mode 100644
index 0000000..84a43a8
--- /dev/null
+++ b/meta-attic/recipes-demo-hmi/windowmanager/windowmanager_git.bb
@@ -0,0 +1,37 @@
+SUMMARY = "AGL WindowManager Application"
+DESCRIPTION = "WindowManager"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+S = "${WORKDIR}/git/"
+
+inherit qmake5 systemd
+DEPENDS = " qtbase "
+
+# for WindowManager:
+DEPENDS += " wayland-ivi-extension "
+
+LIC_FILES_CHKSUM = "file://windowmanager/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+SRCREV = "eeedc5e9e67917bd3346dbe5332e667757a3b28d"
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/windowmanager.git;protocol=https;branch=${AGL_BRANCH}"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+do_install() {
+ install -d ${D}/usr/AGL/${PN}
+ install -m 0755 ${B}/windowmanager/WindowManager ${D}/usr/AGL/${PN}/
+
+ install -d ${D}${systemd_user_unitdir}
+ install -m 0644 ${S}/windowmanager/conf/WindowManager.service ${D}${systemd_user_unitdir}
+ install -m 0644 ${S}/windowmanager/conf/WindowManager.path ${D}${systemd_user_unitdir}
+
+ install -d ${D}${sysconfdir}/systemd/user/default.target.wants
+ ln -sf ${systemd_user_unitdir}/WindowManager.path ${D}${sysconfdir}/systemd/user/default.target.wants
+}
+
+FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"
+FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
+