summaryrefslogtreecommitdiffstats
path: root/meta-sota/recipes-sota/ostree/ostree_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota/recipes-sota/ostree/ostree_git.bb')
-rw-r--r--meta-sota/recipes-sota/ostree/ostree_git.bb14
1 files changed, 11 insertions, 3 deletions
diff --git a/meta-sota/recipes-sota/ostree/ostree_git.bb b/meta-sota/recipes-sota/ostree/ostree_git.bb
index f917f8a..674c379 100644
--- a/meta-sota/recipes-sota/ostree/ostree_git.bb
+++ b/meta-sota/recipes-sota/ostree/ostree_git.bb
@@ -8,7 +8,9 @@ INHERIT_remove_class-native = "systemd"
SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
-SRCREV="0817be61a17cc8b770cad54196182ac9c3109caf"
+SRCREV="3b09620c2738bce4ed45e099cf2e4c5df7671d39"
+
+PV = "2017.3-31-g3b09620c"
S = "${WORKDIR}/git"
@@ -17,12 +19,18 @@ BBCLASSEXTEND = "native"
DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs systemd gtk-doc-native"
DEPENDS_remove_class-native = "systemd-native"
-RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz"
+RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz bash"
RDEPENDS_${PN}_remove_class-native = "python-native"
-EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man --with-smack"
+EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man --with-smack --with-builtin-grub2-mkconfig"
EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat"
+# Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the
+# do_configure stage so we do depend on it
+SYSROOT_DIR = "${STAGING_DIR_TARGET}"
+SYSROOT_DIR_class-native = "${STAGING_DIR_NATIVE}"
+do_configure[vardeps] += "SYSROOT_DIR"
+
SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
SYSTEMD_REQUIRED_class-native = ""