aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>2021-10-09 01:04:04 +0200
committerVasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>2021-10-09 01:04:04 +0200
commit99dfbfbb33644307b742565337ff5793b386bb19 (patch)
tree7dd0e24db9d243336fbc948ea2e75576ea6e82c1
parentc4324a9580521bbc7803897fd7033fd2c5e64db7 (diff)
linux: Update Wi-Fi/BT patches for Renesas BSP v5.1.0.sandbox/opsyvvavrychuk/bsp510-wifi
Adapt to rename done in repo: https://github.com/renesas-rcar/linux-bsp.git branch: v5.10/rcar-5.0.0.rc5 commit: 052e99d arm64: dts: renesas: Rename r8a7795{-es1,}* to r8a7795[01]* Remove patch already present in newer kernel. Issue: COQOS-9061, COQOS-9892 Change-Id: I932a6dc2248b04066db0c35fd4a072f555c40eed
-rw-r--r--meta-agl-refhw-gen3/recipes-kernel/linux/files/0001-Add-support-for-TI-WL1837.patch10
-rw-r--r--meta-agl-refhw-gen3/recipes-kernel/linux/files/0002-revert-e233201a.patch47
-rw-r--r--meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend1
3 files changed, 5 insertions, 53 deletions
diff --git a/meta-agl-refhw-gen3/recipes-kernel/linux/files/0001-Add-support-for-TI-WL1837.patch b/meta-agl-refhw-gen3/recipes-kernel/linux/files/0001-Add-support-for-TI-WL1837.patch
index cfd1276..91fce98 100644
--- a/meta-agl-refhw-gen3/recipes-kernel/linux/files/0001-Add-support-for-TI-WL1837.patch
+++ b/meta-agl-refhw-gen3/recipes-kernel/linux/files/0001-Add-support-for-TI-WL1837.patch
@@ -7,7 +7,7 @@ Signed-off-by: ito.yoshiki001 <ito.yoshiki001@jp.panasonic.com>
Reworked:
- WL1837 specific devicetree configuration moved to the board
- specific r8a7795-agl-refhw.dts from agl-refhw-common.dtsi.
+ specific r8a77951-agl-refhw.dts from agl-refhw-common.dtsi.
- Switched to HCI_LL driver for BT support to match other upstream
users and prepare for btwilink driver going away (dropped in 5.5
upstream).
@@ -21,7 +21,7 @@ Reworked:
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
---
arch/arm64/boot/dts/renesas/agl-refhw-common.dtsi | 37 +++++++---
- arch/arm64/boot/dts/renesas/r8a7795-agl-refhw.dts | 84 ++++++++++++++++++-----
+ arch/arm64/boot/dts/renesas/r8a77951-agl-refhw.dts | 84 ++++++++++++++++++-----
2 files changed, 94 insertions(+), 27 deletions(-)
diff --git a/arch/arm64/boot/dts/renesas/agl-refhw-common.dtsi b/arch/arm64/boot/dts/renesas/agl-refhw-common.dtsi
@@ -95,10 +95,10 @@ index 796ac4c078e0..6f34b54c6ce1 100644
&usb_extal_clk {
clock-frequency = <50000000>;
};
-diff --git a/arch/arm64/boot/dts/renesas/r8a7795-agl-refhw.dts b/arch/arm64/boot/dts/renesas/r8a7795-agl-refhw.dts
+diff --git a/arch/arm64/boot/dts/renesas/r8a77951-agl-refhw.dts b/arch/arm64/boot/dts/renesas/r8a77951-agl-refhw.dts
index 83638a6228c0..97cc6e08ee8f 100644
---- a/arch/arm64/boot/dts/renesas/r8a7795-agl-refhw.dts
-+++ b/arch/arm64/boot/dts/renesas/r8a7795-agl-refhw.dts
+--- a/arch/arm64/boot/dts/renesas/r8a77951-agl-refhw.dts
++++ b/arch/arm64/boot/dts/renesas/r8a77951-agl-refhw.dts
@@ -119,6 +119,23 @@
};
};
diff --git a/meta-agl-refhw-gen3/recipes-kernel/linux/files/0002-revert-e233201a.patch b/meta-agl-refhw-gen3/recipes-kernel/linux/files/0002-revert-e233201a.patch
deleted file mode 100644
index 76039be..0000000
--- a/meta-agl-refhw-gen3/recipes-kernel/linux/files/0002-revert-e233201a.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-Revert "wl18xx: do not invert IRQ on WLxxxx side"
-
-This reverts commit 2bcfc394307ae164cbbdff74b902af61dc0181b4.
-The hard-coded assumption that the IRQ inversion logic is not
-needed breaks non-Kingfisher users, specifically the WLAN card
-for the AGL reference hardware board.
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
----
- drivers/net/wireless/ti/wl18xx/main.c | 8 --------
- 1 file changed, 8 deletions(-)
-
-diff --git a/drivers/net/wireless/ti/wl18xx/main.c b/drivers/net/wireless/ti/wl18xx/main.c
-index 764987101116..0b3cf8477c6c 100644
---- a/drivers/net/wireless/ti/wl18xx/main.c
-+++ b/drivers/net/wireless/ti/wl18xx/main.c
-@@ -865,9 +865,7 @@ static int wl18xx_pre_upload(struct wl1271 *wl)
- {
- u32 tmp;
- int ret;
--#if 0
- u16 irq_invert;
--#endif
-
- BUILD_BUG_ON(sizeof(struct wl18xx_mac_and_phy_params) >
- WL18XX_PHY_INIT_MEM_SIZE);
-@@ -920,11 +918,6 @@ static int wl18xx_pre_upload(struct wl1271 *wl)
- if (ret < 0)
- goto out;
-
--#if 0
-- /* We have level translator with inversion on IRQ line so we
-- * set IRQ_TYPE_EDGE_FALLING in DTS, but we do not need to
-- * invert IRQ logic on WLxxxx side!
-- */
- ret = irq_get_trigger_type(wl->irq);
- if ((ret == IRQ_TYPE_LEVEL_LOW) || (ret == IRQ_TYPE_EDGE_FALLING)) {
- wl1271_info("using inverted interrupt logic: %d", ret);
-@@ -944,7 +937,6 @@ static int wl18xx_pre_upload(struct wl1271 *wl)
-
- ret = wlcore_set_partition(wl, &wl->ptable[PART_PHY_INIT]);
- }
--#endif
-
- out:
- return ret;
diff --git a/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
index 325e507..c5002bb 100644
--- a/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
+++ b/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -5,7 +5,6 @@ SRC_URI_append = " \
file://0001-add-agl-refhw.patch \
file://0003-rcar3-dw-hdmi-cec-mute.patch \
file://0001-Add-support-for-TI-WL1837.patch \
- file://0002-revert-e233201a.patch \
file://refhw-rcar.cfg \
"