aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-04-03 18:09:03 -0400
committerScott Murray <scott.murray@konsulko.com>2022-04-03 18:14:11 -0400
commit27785f1c4d0f9de2025a5ba9504651fb651f74d1 (patch)
tree454e484fef84e614bc77d7d4e1a49d1526315cc1
parent92da06f999511ebf5f871ec40dffd3cb456be55f (diff)
Updates for kirkstone
Changes: - Updated LAYERSERIES_COMPAT. - Updated override syntax via a combination of the conversion script in poky and manual inspection. - Updated a license field viarunning the conversion script in poky. - Updated branches in README, further updates will likely be required when an official Renesas BSP release is made. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6f736f56a23ddb634232e5c99e21830bc6637764
-rw-r--r--README8
-rw-r--r--meta-agl-refhw-gen3/conf/layer.conf2
-rw-r--r--meta-agl-refhw-gen3/conf/machine/agl-refhw-h3.conf6
-rw-r--r--meta-agl-refhw-gen3/docs/ReferenceHW_Rcar_gen3.md6
-rw-r--r--meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend14
-rw-r--r--meta-agl-refhw-gen3/recipes-bsp/ti-bt-firmware/ti-bt-firmware_git.bb2
-rw-r--r--meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb8
-rw-r--r--meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend6
8 files changed, 25 insertions, 27 deletions
diff --git a/README b/README
index 29d6040..ed7bcd8 100644
--- a/README
+++ b/README
@@ -9,16 +9,14 @@ This layer depends on:
URI: git://git.openembedded.org/openembedded-core
layers: meta
- branch: dunfell
+ branch: kirkstone
URI: git://git.openembedded.org/meta-openembedded
layers: meta-oe, meta-python
- branch: dunfell
+ branch: kirkstone
URI: https://github.com/renesas-rcar/meta-renesas
- branch: dunfell
- - Note that the Renesas-Yocto-v5.5.0 tag is currently the latest revision
- verified as compatible, it is recommended that it be used.
+ branch: kirkstone-dev_3.5_M3_v5.9.0
Build Instructions
diff --git a/meta-agl-refhw-gen3/conf/layer.conf b/meta-agl-refhw-gen3/conf/layer.conf
index 5bf71f5..09c47bb 100644
--- a/meta-agl-refhw-gen3/conf/layer.conf
+++ b/meta-agl-refhw-gen3/conf/layer.conf
@@ -15,6 +15,6 @@ BBFILE_PRIORITY_agl-refhw-gen3 = "11"
LAYERDEPENDS_agl-refhw-gen3 = "core rcar-gen3"
-LAYERSERIES_COMPAT_agl-refhw-gen3 = "dunfell"
+LAYERSERIES_COMPAT_agl-refhw-gen3 = "kirkstone"
LICENSE_PATH += "${LAYERDIR}/licenses"
diff --git a/meta-agl-refhw-gen3/conf/machine/agl-refhw-h3.conf b/meta-agl-refhw-gen3/conf/machine/agl-refhw-h3.conf
index 97c4854..1cde865 100644
--- a/meta-agl-refhw-gen3/conf/machine/agl-refhw-h3.conf
+++ b/meta-agl-refhw-gen3/conf/machine/agl-refhw-h3.conf
@@ -8,9 +8,9 @@ require conf/machine/salvator-x.conf
# we would want the ordering salvator-x:<machine>, but that is
# non-trivial to accomplish and not absolutely necessary for our
# expected use.
-MACHINEOVERRIDES_append = ":salvator-x"
+MACHINEOVERRIDES:append = ":salvator-x"
# Reference hardware has USB3
-MACHINE_FEATURES_append = " usb3"
+MACHINE_FEATURES:append = " usb3"
-KERNEL_DEVICETREE_append = " renesas/r8a77951-agl-refhw.dtb"
+KERNEL_DEVICETREE:append = " renesas/r8a77951-agl-refhw.dtb"
diff --git a/meta-agl-refhw-gen3/docs/ReferenceHW_Rcar_gen3.md b/meta-agl-refhw-gen3/docs/ReferenceHW_Rcar_gen3.md
index dcaab5b..974be84 100644
--- a/meta-agl-refhw-gen3/docs/ReferenceHW_Rcar_gen3.md
+++ b/meta-agl-refhw-gen3/docs/ReferenceHW_Rcar_gen3.md
@@ -205,11 +205,11 @@ download.
It is also possible to build the firmware outside of the AGL build by using this
BSP layer on top of the meta-rcar-gen3 layer in meta-renesas.
-1. In a temporary working directory, clone poky the poky repository and check out the dunfell branch:
+1. In a temporary working directory, clone poky the poky repository and check out the kirkstone branch:
```
git clone git://git.yoctoproject.org/poky
cd poky
- git checkout dunfell
+ git checkout kirkstone
..
```
2. Clone the Renesas BSP and it's dependent layers:
@@ -220,7 +220,7 @@ BSP layer on top of the meta-rcar-gen3 layer in meta-renesas.
cd ..
git clone git://git.openembedded.org/meta-openembedded
cd meta-openembedded
- git checkout dunfell
+ git checkout kirkstone
cd ..
```
3. Clone the reference hardware BSP layer:
diff --git a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
index b02096f..8680d63 100644
--- a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
+++ b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
@@ -1,16 +1,16 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI_append_rcar-gen3 = " file://0001-rcar_gen3-plat-Do-not-panic-on-unrecognized-boards.patch"
+SRC_URI:append:rcar-gen3 = " file://0001-rcar_gen3-plat-Do-not-panic-on-unrecognized-boards.patch"
# Apply the patch AGL applies for all rcar3 in meta-agl-bsp when
# building the standalone agl-refhw-h3 machine.
-SRC_URI_append_agl-refhw-h3 = " file://0001-Boot-Normal-World-in-EL2.patch"
+SRC_URI:append:agl-refhw-h3 = " file://0001-Boot-Normal-World-in-EL2.patch"
# It is believed the eMMC configuration below makes the result AGL
# reference hardware specific, mark it as such when building with
# MACHINE=agl-refhw-h3 to potentially flag this in an incorrectly
# configured build.
-COMPATIBLE_MACHINE_agl-refhw-h3 = "agl-refhw-h3"
+COMPATIBLE_MACHINE:agl-refhw-h3 = "agl-refhw-h3"
# There are hardware issues in using hyperflash. arm-trusted-firmware, optee and
# u-boot have to be stored into eMMC by using serial donwload.
@@ -32,7 +32,7 @@ DDR_8G_OPTION = "RCAR_DRAM_LPDDR4_MEMCONF=1 RCAR_DRAM_MEMRANK=2"
# and please flash the firmware built with the following options.
DDR_8G_1RANK_OPTION = "RCAR_DRAM_LPDDR4_MEMCONF=1 RCAR_DRAM_MEMRANK=1"
-ATFW_OPT_agl-refhw-h3 = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}"
+ATFW_OPT:agl-refhw-h3 = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}"
#
# Handle building as extra firmware with MACHINE=h3ulcb
@@ -62,11 +62,11 @@ H3[4x2g-1rank] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_1RANK_OP
# upstream.
#
-do_compile_prepend() {
+do_compile:prepend() {
oe_runmake distclean PLAT=${PLATFORM} MBEDTLS_COMMON_MK=1 ${ATFW_OPT}
}
-do_ipl_opt_compile_prepend() {
+do_ipl_opt_compile:prepend() {
oe_runmake distclean PLAT=${PLATFORM} MBEDTLS_COMMON_MK=1 ${ATFW_OPT}
}
diff --git a/meta-agl-refhw-gen3/recipes-bsp/ti-bt-firmware/ti-bt-firmware_git.bb b/meta-agl-refhw-gen3/recipes-bsp/ti-bt-firmware/ti-bt-firmware_git.bb
index 22d9145..b4f8564 100644
--- a/meta-agl-refhw-gen3/recipes-bsp/ti-bt-firmware/ti-bt-firmware_git.bb
+++ b/meta-agl-refhw-gen3/recipes-bsp/ti-bt-firmware/ti-bt-firmware_git.bb
@@ -23,4 +23,4 @@ do_install() {
oe_runmake "DEST_DIR=${D}" "BASE_LIB_DIR=${nonarch_base_libdir}" install
}
-FILES_${PN} = "${nonarch_base_libdir}/firmware/ti-connectivity/*"
+FILES:${PN} = "${nonarch_base_libdir}/firmware/ti-connectivity/*"
diff --git a/meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb b/meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb
index 42a3248..477c5a9 100644
--- a/meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb
+++ b/meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb
@@ -1,10 +1,10 @@
DESCRIPTION = "Configuration utility for TI wireless drivers"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://README;beginline=1;endline=21;md5=adc05a1903d3f107f85c90328e3a9438"
# Tag: R8.7_SP3 (8.7.3)
SRCREV = "5048b59a444ac59ba7171d6e122d5a84581aebf2"
-SRC_URI = "git://git.ti.com/wilink8-wlan/18xx-ti-utils.git"
+SRC_URI = "git://git.ti.com/wilink8-wlan/18xx-ti-utils.git;branch=master"
S = "${WORKDIR}/git/wlconf"
@@ -30,10 +30,10 @@ do_install() {
${D}${sbindir}/wlconf/official_inis/
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${sbindir}/wlconf \
${sbindir}/wlconf/official_inis \
/lib/firmware/ti-connectivity/wl18xx-conf.bin \
"
-FILES_${PN}-dbg += "${sbindir}/wlconf/.debug" \ No newline at end of file
+FILES:${PN}-dbg += "${sbindir}/wlconf/.debug"
diff --git a/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
index fee4c77..8df2fbc 100644
--- a/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
+++ b/meta-agl-refhw-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -1,6 +1,6 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI_append = " \
+SRC_URI:append = " \
file://0001-Create-r8a7795-USB-OVC-pin-groups.patch \
file://0002-Add-AGL-reference-hardware-support.patch \
file://0003-Add-support-for-TI-WL1837.patch \
@@ -8,4 +8,4 @@ SRC_URI_append = " \
file://refhw-rcar.cfg \
"
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/refhw-rcar.cfg"
+KERNEL_CONFIG_FRAGMENTS:append = " ${WORKDIR}/refhw-rcar.cfg"