aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-10-26 16:18:22 -0400
committerScott Murray <scott.murray@konsulko.com>2021-10-26 16:18:22 -0400
commitc79268a6d2d2a5445e8fdfd4bb7af536cdab7115 (patch)
treeea1d0ba5cba93469a9f425c5c275a01cf4e7b394
parent6edf7ba825e36068cb5d8e3a4d9f9f9920d68ac6 (diff)
arm-trusted-firmware: build 1rank firmware when MACHINE=agl-refhw-h3
Tweak the arm-trusted-firmware bbappend to build the extra 1rank firmware when building standalone with MACHINE=agl-refhw-h3, and also add an anonymous python snippet to disable the default firmware configurations from the base recipe in that situation as well, as they are not useful. Bug-AGL: SPEC-4115 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I4697476b08c9dfc722cc8e97c837786874869262
-rw-r--r--meta-agl-refhw-gen3/docs/ReferenceHW_Rcar_gen3.md2
-rw-r--r--meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend12
2 files changed, 13 insertions, 1 deletions
diff --git a/meta-agl-refhw-gen3/docs/ReferenceHW_Rcar_gen3.md b/meta-agl-refhw-gen3/docs/ReferenceHW_Rcar_gen3.md
index 3f757e0..0e60a22 100644
--- a/meta-agl-refhw-gen3/docs/ReferenceHW_Rcar_gen3.md
+++ b/meta-agl-refhw-gen3/docs/ReferenceHW_Rcar_gen3.md
@@ -130,7 +130,7 @@ download.
files under the build directory in `tmp/deploy/images/h3ulcb`.
If you use the reference hardware numbered 100 or above,
- please flash the firmware with the suffix "-agl-refhw-4x2g-1rank".
+ please flash the firmware with the suffix "-4x2g-1rank".
The firmware should be stored on the eMMC as follows:
diff --git a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
index 564e0b5..038e0a4 100644
--- a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
+++ b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
@@ -42,6 +42,18 @@ ATFW_OPT_agl-refhw-h3 = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_O
H3ULCB[agl-refhw-4x2g] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}"
H3ULCB[agl-refhw-4x2g-1rank] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_1RANK_OPTION}"
+python __anonymous() {
+ # If building for MACHINE=agl-refhw-h3, the predefined default
+ # extra configurations in the base recipe are not interesting
+ # to us, as there is no compatible hardware.
+ if d.getVar("MACHINE") == "agl-refhw-h3":
+ d.delVarFlag("H3", "2x2g")
+ d.delVarFlag("H3", "4x2g")
+}
+
+# Also build the extra 1rank firmware when MACHINE=agl-refhw-h3
+H3[4x2g-1rank] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_1RANK_OPTION}"
+
#
# Need to prepend the compile tasks with a distclean that actually cleans
# out all the platform specific files like the new rcar_layout_tool output,