aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-refhw-gen3/recipes-bsp
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-10-20 16:37:05 -0400
committerScott Murray <scott.murray@konsulko.com>2020-10-20 16:37:05 -0400
commite3a57dcb2ae1cd4e6a81e1ca65ac235c8e3dd500 (patch)
tree0878ba459734324815e2aafbdca8de353993a486 /meta-agl-refhw-gen3/recipes-bsp
parent16813d0d76cfb16469ec2550e48309deca357278 (diff)
Initial check-in
Initial check-in of the contents of the meta-refhw directory from the AGL_Refhw_sample_software_20200512.tar.gz archive provided by Panasonic as the initial BSP for the AGL reference hardware. The only change from the files as provided is that unneeded execute file permissions have been removed. Bug-AGL: SPEC-3658 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-refhw-gen3/recipes-bsp')
-rw-r--r--meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
new file mode 100644
index 0000000..1fccf80
--- /dev/null
+++ b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
@@ -0,0 +1,26 @@
+#FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
+
+# There are hardware issues in using hyperflash. arm-trusted-firmware, optee and
+# u-boot have to be stored into eMMC by using serial donwload.
+EMMC_BOOT_OPTION = "RCAR_SA6_TYPE=1"
+
+DDR_8G_OPTION= "RCAR_DRAM_LPDDR4_MEMCONF=1"
+
+ATFW_OPT_append_refhw = " ${EMMC_BOOT_OPTION} "
+
+# In arm-trusted-firmware-control.inc, a "extra_ipl_opt" task is appended to
+# create firmware for 4x2g or 2x2g variation. it is supposed to use
+# EXTRA_ATFW_OPT to customize the compiler opton.
+#
+#EXTRA_ATFW_OPT_append_refhw = " ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION} "
+#
+# Unfortunately in do_extra_ipl_opt() it use d.setVar() instead of d.appendVar()
+# to setup EXTRA_ATFW_OPT variable which makes it impossible to customize it properly
+# by others... Override it.
+#
+#
+do_ipl_opt_compile_refhw () {
+ oe_runmake distclean
+ oe_runmake bl2 bl31 dummytool PLAT=${PLATFORM} ${EXTRA_ATFW_OPT} ${ATFW_OPT_LOSSY} ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}
+}
+